[erledigt] SSLError: ("bad handshake: Error([('SSL routines', 'tls_process_server_certificate', 'certificate ve

Twilo
- Welche Version von pd-admin wird eingesetzt? 4.56
- Welche Version der Serverumgebung wird eingesetzt? 0.295
- Welche Fehlermeldung erhalten Sie? s.u.
code:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
XX:~
>/opt/pdadmin/bin/letsencrypt www.XXX.de
[…]
Saving debug log to /var/log/letsencrypt/letsencrypt.log
An unexpected error occurred:
SSLError: ("bad handshake: Error([('SSL routines', 'tls_process_server_certificate', 'certificate verify failed')],)",)
Please see the logfiles in /var/log/letsencrypt for more details.
certbot-auto failedWriting /usr/local/pd-admin2/conf/httpd.conf
Writing /usr/local/pd-admin2/httpd-2.4/conf/httpd.conf
webserver = <AP22>
Apache 22 is already selected

code:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
2017-09-05 08:43:11,374:DEBUG:certbot.main:certbot version: 0.17.0
2017-09-05 08:43:11,375:DEBUG:certbot.main:Arguments: ['--agree-tos', '--non-interactive', '--email', 'daniel@bradler.com', '--keep-until-expiring', '--expand', '--webroot', '-w', '/opt/pdadmin/etc/ssl-validation/', '-d', 'www.XXX.de', '-d', 'XXX.de']
2017-09-05 08:43:11,375:DEBUG:certbot.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#apache,PluginEntryPoint#manual,PluginEntryPoint#nginx,PluginEntryPoint#null,PluginEntryPoint#standalone,PluginEntryPoint#webroot)
2017-09-05 08:43:11,388:DEBUG:certbot.log:Root logging level set at 20
2017-09-05 08:43:11,388:INFO:certbot.log:Saving debug log to /var/log/letsencrypt/letsencrypt.log
2017-09-05 08:43:11,396:DEBUG:certbot.plugins.selection:Requested authenticator webroot and installer None
2017-09-05 08:43:11,399:DEBUG:certbot.plugins.selection:Single candidate plugin: * webroot
Description: Place files in webroot directory
Interfaces: IAuthenticator, IPlugin
Entry point: webroot = certbot.plugins.webroot:Authenticator
Initialized: <certbot.plugins.webroot.Authenticator object at 0x7f9202487150>
Prep: True
2017-09-05 08:43:11,400:DEBUG:certbot.plugins.selection:Selected authenticator <certbot.plugins.webroot.Authenticator object at 0x7f9202487150> and installer None
2017-09-05 08:43:11,530:DEBUG:acme.client:Sending GET request to https://acme-v01.api.letsencrypt.org/directory.
2017-09-05 08:43:11,533:DEBUG:requests.packages.urllib3.connectionpool:Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org
2017-09-05 08:43:21,567:DEBUG:certbot.log:Exiting abnormally:
Traceback (most recent call last):
  File "/root/.local/share/letsencrypt/bin/letsencrypt", line 11, in <module>
    sys.exit(main())
  File "/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/main.py", line 753, in main
    return config.func(config, plugins)
  File "/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/main.py", line 676, in certonly
    le_client = _init_le_client(config, auth, installer)
  File "/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/main.py", line 390, in _init_le_client
    acc, acme = _determine_account(config)
  File "/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/main.py", line 375, in _determine_account
    config, account_storage, tos_cb=_tos_cb)
  File "/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/client.py", line 163, in register
    acme = acme_from_config_key(config, key)
  File "/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/client.py", line 45, in acme_from_config_key
    return acme_client.Client(config.server, key=key, net=net)
  File "/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/acme/client.py", line 71, in __init__
    self.net.get(directory).json())
  File "/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/acme/client.py", line 654, in get
    self._send_request('GET', url, **kwargs), content_type=content_type)
  File "/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/acme/client.py", line 627, in _send_request
    response = self.session.request(method, url, *args, **kwargs)
  File "/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/requests/sessions.py", line 488, in request
    resp = self.send(prep, **send_kwargs)
  File "/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/requests/sessions.py", line 609, in send
    r = adapter.send(request, **kwargs)
  File "/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/requests/adapters.py", line 497, in send
    raise SSLError(e, request=request)
SSLError: ("bad handshake: Error([('SSL routines', 'tls_process_server_certificate', 'certificate verify failed')],)",)

woran kann das liegen?

mfg
Twilo
Twilo
Hallo,

beim erneutem Lauf wurde certbot-auto von 0.17.0 auf 0.18.0 aktualisiert; seit dem funktioniert es Freude

mfg
Twilo