pdadmin-forum

pdadmin-forum » Archive » Bug-Report Archiv » [Kein Bug] Backupfehler bei V4.03 SE 0.100 » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Zum Ende der Seite springen Backupfehler bei V4.03 SE 0.100
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
tomcat
Mitglied


Dabei seit: 02.01.2006
Beiträge: 199

Backupfehler bei V4.03 SE 0.100 Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hallo,

bei _allen_ Servern, auf denen ich V4 _neu_ installiert habe, bricht die Backuproutine mit einer Fehlermeldung ab. Das Problem ist die setuidgid Anweisung in Zeile 38 der Datei backup_user.sh. Wenn ich die setuidgid Anweisung entferne, gibt es keine Fehlermeldungen.

Bei den Dateirechten ist mir nichts auffälliges aufgefallen - dennoch scheint mir hier der Hund begraben zu sein.

Was genau ist das Problem und wie kann es behoben werden? Das scheint mir ein waschechter Bug zu sein, denn die Installs sind alle Standard-F.

code:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
b07:~# /opt/pdadmin/bin/backup.pl
tar: Entferne führende »/« von Elementnamen
tar: Entferne führende »/« von Elementnamen
tar: Entferne führende »/« von Elementnamen
tar: Entferne führende »/« von Elementnamen
tar: Entferne führende »/« von Elementnamen
tar: Entferne führende »/« von Elementnamen
tar: /backups/user/aratrdbl/0/backup.tar.gz: Kann open nicht ausführen: Keine Berechtigung
tar: Nicht behebbarer Fehler: Programmabbruch.
tar: Entferne führende »/« von Elementnamen

gzip: stdout: Broken pipe
tar: /backups/user/aratrdbl/0/backup.tar.gz: Nur 2048 von 10240 Bytes geschrieben
tar: Nicht behebbarer Fehler: Programmabbruch.
tar: /backups/user/arascdbb/0/backup.tar.gz: Kann open nicht ausführen: Keine Berechtigung
tar: Nicht behebbarer Fehler: Programmabbruch.
tar: Entferne führende »/« von Elementnamen

gzip: stdout: Broken pipe
tar: /backups/user/arascdbb/0/backup.tar.gz: Nur 8192 von 10240 Bytes geschrieben
tar: Nicht behebbarer Fehler: Programmabbruch.
tar: /backups/user/notdinbu/0/backup.tar.gz: Kann open nicht ausführen: Keine Berechtigung
tar: Nicht behebbarer Fehler: Programmabbruch.
tar: Entferne führende »/« von Elementnamen

gzip: stdout: Broken pipe
tar: /backups/user/notdinbu/0/backup.tar.gz: Kann write nicht ausführen: Datenübergabe unterbrochen (broken pipe)
tar: Nicht behebbarer Fehler: Programmabbruch.


code:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
b07:/opt/pdadmin/bin# ls -la
insgesamt 3404
drwxr-xr-x  2 root root    4096 2007-06-13 11:07 .
drwxr-xr-x 11 root root    4096 2007-12-27 09:54 ..
-rwxr-x---  1 root root    1206 2007-03-13 12:01 assign.pl
-rwxr-xr-x  1 root root     724 2007-03-13 12:01 backup_mysql.sh
-rwxr-xr-x  1 root root    3139 2007-03-13 12:01 backup.pl
-rwxr-xr-x  1 root root    1644 2007-03-13 12:01 backup_system.sh
-rwxr-xr-x  1 root root    1020 2007-03-13 12:01 backup_user.sh
-rwxr-xr-x  1 root root     149 2007-03-13 12:01 backup_write_dump.sh
...

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von tomcat: 28.12.2007 09:21.

28.12.2007 09:20 tomcat ist offline E-Mail an tomcat senden Beiträge von tomcat suchen Nehme tomcat in Deine Freundesliste auf
Daniel Bradler
PD-Admin Dev

Dabei seit: 11.09.2004
Beiträge: 2.234

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Das kann ich nicht bestätigen. Vermutlich hat $backup_dir die falsche Berechtigung, richtig ist 755.

Viele Grüße,
Daniel Bradler
28.12.2007 10:44 Daniel Bradler ist offline Beiträge von Daniel Bradler suchen Nehme Daniel Bradler in Deine Freundesliste auf
tomcat
Mitglied


Dabei seit: 02.01.2006
Beiträge: 199

Themenstarter Thema begonnen von tomcat
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Korrekt, das wars. Danke - kein Bug! Userbug.
28.12.2007 10:50 tomcat ist offline E-Mail an tomcat senden Beiträge von tomcat suchen Nehme tomcat in Deine Freundesliste auf
Baumstruktur | Brettstruktur
Gehe zu:
pdadmin-forum » Archive » Bug-Report Archiv » [Kein Bug] Backupfehler bei V4.03 SE 0.100

Impressum | Team | Hilfe

Forensoftware: Burning Board, entwickelt von WoltLab GmbH    |    Design entwickelt von You-Online.de