pdadmin-forum

pdadmin-forum » Information » Add-On Diskussionen » AddOn: Uptime (PDA Admin-Bereich) » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Neues Thema erstellen Antwort erstellen
Zum Ende der Seite springen AddOn: Uptime (PDA Admin-Bereich)
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
Twilo
Moderator


images/avatars/avatar-5.png

Dabei seit: 12.09.2004
Beiträge: 2.829
Herkunft: Berlin

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Addon zu dieser Diskussion: AddOn: Uptime (PDA Admin-Bereich)

Hallo,

bei mir kommt da keine Ausgabe

nehme ich statt "top b n 1" -> "uptime" klappt es
woran könnte das liegen?

bei top... steht zwischen <pre></pre> nix, es werden also keine Daten abgerufen

in der error.log taucht folgendes auf
Zitat:
TERM environment variable not set.


mfg
Twilo

__________________
Wunschzettel smile
Farbtabelle
13.03.2005 19:14 Twilo ist offline Homepage von Twilo Beiträge von Twilo suchen Nehme Twilo in Deine Freundesliste auf
miko93
Moderator


images/avatars/avatar-2.gif

Dabei seit: 08.09.2004
Beiträge: 1.012
Herkunft: Regensburg, Germany

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hm. Gute Frage. Ersetze ich das "top..." durch my $addon_data1 = `echo \$TERM`;, so erhalte ich die Ausgabe "dumb", während echo $TERM auf der Konsole ausgibt: xterm.

Vielleicht würde folgende Änderung das Problem bereits lösen:
Zitat:
my $addon_data1 = `export TERM=dumb; /usr/bin/top b n 1`;


__________________
Frage beantwortet? Problem gelöst? Dann markiert euren Beitrag bitte als [erledigt].
14.03.2005 17:31 miko93 ist offline E-Mail an miko93 senden Homepage von miko93 Beiträge von miko93 suchen Nehme miko93 in Deine Freundesliste auf
Twilo
Moderator


images/avatars/avatar-5.png

Dabei seit: 12.09.2004
Beiträge: 2.829
Herkunft: Berlin

Themenstarter Thema begonnen von Twilo
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hallo,

so klappt es :-)

ps. kannst du mir sagen, wie ich die httpd_vhosts.pl ein binden kann? smile

mfg
Teilo

__________________
Wunschzettel smile
Farbtabelle
14.03.2005 18:18 Twilo ist offline Homepage von Twilo Beiträge von Twilo suchen Nehme Twilo in Deine Freundesliste auf
Damaskus
Mitglied


images/avatars/avatar-20.png

Dabei seit: 20.03.2005
Beiträge: 94

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hi,
bei mir kommt folgende Fehlermeldung:

code:
1:
The requested URL /administrator/sid/387d3d42cf6811dea169d236ccf24b907dc3/addon_uptime.cgi was not found on this server.


Kann mir jemand weiterhelfen?

Thx
20.03.2005 14:55 Damaskus ist offline Beiträge von Damaskus suchen Nehme Damaskus in Deine Freundesliste auf
Twilo
Moderator


images/avatars/avatar-5.png

Dabei seit: 12.09.2004
Beiträge: 2.829
Herkunft: Berlin

Themenstarter Thema begonnen von Twilo
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hallo,

Zitat:
Original von Damaskus

bei mir kommt folgende Fehlermeldung:
code:
1:
The requested URL /administrator/sid/387d3d42cf6811dea169d236ccf24b907dc3/addon_uptime.cgi was not found on this server.

Kann mir jemand weiterhelfen?

hast du die Datei auch unter /opt/pdadmin/www/administrator/ gespeichert?

mfg
Twilo

__________________
Wunschzettel smile
Farbtabelle
20.03.2005 15:38 Twilo ist offline Homepage von Twilo Beiträge von Twilo suchen Nehme Twilo in Deine Freundesliste auf
Damaskus
Mitglied


images/avatars/avatar-20.png

Dabei seit: 20.03.2005
Beiträge: 94

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Nö,
deshalb klappts auch nicht :oops: :oops: :oops:

THX
20.03.2005 15:40 Damaskus ist offline Beiträge von Damaskus suchen Nehme Damaskus in Deine Freundesliste auf
Damaskus
Mitglied


images/avatars/avatar-20.png

Dabei seit: 20.03.2005
Beiträge: 94

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hi,
irgendwie klappt es trotzdem nicht.
Folgende Fehlermeldung
code:
1:
The server encountered an internal error or misconfiguration and was unable to complete your request.


Die Zugriffsrechte stimmen alle.
Die Dateien sind diesmal alle im richtigen Verzeichnis :wink:

Im Einsatz hab ich die "normale" SE und die aktuellste PDA Version.

Gruß
Damaskus
20.03.2005 17:24 Damaskus ist offline Beiträge von Damaskus suchen Nehme Damaskus in Deine Freundesliste auf
Twilo
Moderator


images/avatars/avatar-5.png

Dabei seit: 12.09.2004
Beiträge: 2.829
Herkunft: Berlin

Themenstarter Thema begonnen von Twilo
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hallo,

hast du die Datei auch über pd-admin aufgerufen?
diese Meldung bekomme ich nur, wenn ich die Datei dirkt aufrufe, oder die Session ungültig ist

mfg
Twilo

__________________
Wunschzettel smile
Farbtabelle
20.03.2005 17:58 Twilo ist offline Homepage von Twilo Beiträge von Twilo suchen Nehme Twilo in Deine Freundesliste auf
Damaskus
Mitglied


images/avatars/avatar-20.png

Dabei seit: 20.03.2005
Beiträge: 94

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Ja.
Ich hab den Aufruf direkt über das Adminmenü gemacht.
20.03.2005 18:08 Damaskus ist offline Beiträge von Damaskus suchen Nehme Damaskus in Deine Freundesliste auf
Twilo
Moderator


images/avatars/avatar-5.png

Dabei seit: 12.09.2004
Beiträge: 2.829
Herkunft: Berlin

Themenstarter Thema begonnen von Twilo
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hallo,

ist vielleicht nach
code:
1:
#!/usr/local/bin/perl -w

ein Windows Zeilenumbruch?
ich weiss von PHP, dass danach keiner sein darf

mfg
Twilo

__________________
Wunschzettel smile
Farbtabelle
20.03.2005 18:13 Twilo ist offline Homepage von Twilo Beiträge von Twilo suchen Nehme Twilo in Deine Freundesliste auf
Damaskus
Mitglied


images/avatars/avatar-20.png

Dabei seit: 20.03.2005
Beiträge: 94

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hi,
ich hab das Script direkt aus dem Forum kopiert.
Wie meinst du das mit dem Windows Zeilenumbruch?
20.03.2005 18:52 Damaskus ist offline Beiträge von Damaskus suchen Nehme Damaskus in Deine Freundesliste auf
Twilo
Moderator


images/avatars/avatar-5.png

Dabei seit: 12.09.2004
Beiträge: 2.829
Herkunft: Berlin

Themenstarter Thema begonnen von Twilo
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hallo,

Zitat:
Original von Damaskus

ich hab das Script direkt aus dem Forum kopiert.

ich weiss nicht, ob es dann zu problemen kommen kann
hast du einen Editor, womit du \r\n zu \n konvertieren kannst?
dann mache das mal und lade das Teil hoch und teste es nochmal

Zitat:
Original von Damaskus

Wie meinst du das mit dem Windows Zeilenumbruch?

Windows nimmt folgenden Zeilenumbruch \r\n
es darf aber nur der Linux Zeilenumbruch \n verwendet werden

mfg
Twilo

__________________
Wunschzettel smile
Farbtabelle
20.03.2005 19:01 Twilo ist offline Homepage von Twilo Beiträge von Twilo suchen Nehme Twilo in Deine Freundesliste auf
miko93
Moderator


images/avatars/avatar-2.gif

Dabei seit: 08.09.2004
Beiträge: 1.012
Herkunft: Regensburg, Germany

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Der "internal server error" kommt bei mir so gut wie immer, also auch bei Tippfehlern (oder dem besagten \r\n).
Das httpd-Fehlerlog sollte detailliertere Aussagen machen. Da wäre ich nun schon gespannt drauf ;-)

__________________
Frage beantwortet? Problem gelöst? Dann markiert euren Beitrag bitte als [erledigt].
20.03.2005 20:33 miko93 ist offline E-Mail an miko93 senden Homepage von miko93 Beiträge von miko93 suchen Nehme miko93 in Deine Freundesliste auf
Damaskus
Mitglied


images/avatars/avatar-20.png

Dabei seit: 20.03.2005
Beiträge: 94

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Ich suchs nacher raus.
Und schau auch nach dem Zeilenumbruch.

Gruß
20.03.2005 20:36 Damaskus ist offline Beiträge von Damaskus suchen Nehme Damaskus in Deine Freundesliste auf
Twilo
Moderator


images/avatars/avatar-5.png

Dabei seit: 12.09.2004
Beiträge: 2.829
Herkunft: Berlin

Themenstarter Thema begonnen von Twilo
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hallo,

lösch am besten den Zeilenumbruch mit vi raus und erstelle den mit vi neu smile

mfg
Twilo

__________________
Wunschzettel smile
Farbtabelle
20.03.2005 20:45 Twilo ist offline Homepage von Twilo Beiträge von Twilo suchen Nehme Twilo in Deine Freundesliste auf
Damaskus
Mitglied


images/avatars/avatar-20.png

Dabei seit: 20.03.2005
Beiträge: 94

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hier mal der Auszug aus dem Errorolog der geschrieben wird

code:
1:
2:
3:
4:
5:
6:
[Sun Mar 20 18:45:58 2005] [error] [client 217.87.121.209] Premature end of scri
pt headers: /opt/pdadmin/www/administrator/addon_uptime.cgi
[Sun Mar 20 18:45:58 2005] [error] (8)Exec format error: exec of /opt/pdadmin/ww
w/administrator/addon_uptime.cgi failed
20.03.2005 21:17 Damaskus ist offline Beiträge von Damaskus suchen Nehme Damaskus in Deine Freundesliste auf
Twilo
Moderator


images/avatars/avatar-5.png

Dabei seit: 12.09.2004
Beiträge: 2.829
Herkunft: Berlin

Themenstarter Thema begonnen von Twilo
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hallo,

ich kann damit auf die schnelle nicht viel anfangen...
vielelicht kann jemand anders mit der Fehlermeldung umgehen

mfg
Twilo

__________________
Wunschzettel smile
Farbtabelle
20.03.2005 21:35 Twilo ist offline Homepage von Twilo Beiträge von Twilo suchen Nehme Twilo in Deine Freundesliste auf
Damaskus
Mitglied


images/avatars/avatar-20.png

Dabei seit: 20.03.2005
Beiträge: 94

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Ich hab den Fehler gefunden!
In die Datei addon_uptime.cgi hat sich ein Stückchen html Code reingeschlichen das da nicht hingehört... :roll:
Rausgelöscht und schon klappts.

Thx fürs helfen und sorry für die unnötige Arbeit
20.03.2005 21:41 Damaskus ist offline Beiträge von Damaskus suchen Nehme Damaskus in Deine Freundesliste auf
miko93
Moderator


images/avatars/avatar-2.gif

Dabei seit: 08.09.2004
Beiträge: 1.012
Herkunft: Regensburg, Germany

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Zitat:
...und sorry für die unnötige Arbeit
Neinnein.
Vielen Dank fürs Testen !

__________________
Frage beantwortet? Problem gelöst? Dann markiert euren Beitrag bitte als [erledigt].
21.03.2005 17:43 miko93 ist offline E-Mail an miko93 senden Homepage von miko93 Beiträge von miko93 suchen Nehme miko93 in Deine Freundesliste auf
idnet
Mitglied


Dabei seit: 12.04.2005
Beiträge: 38
Herkunft: Hamburg

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

ich rate allen dazu die html und die cgi, noch mal zu überprüfen, gerade wenn per c&p aus windows der inhalt aus dem forum kopiert wurde. bei mir lag der Internal Server Error daran, das innerhalb der cgi die "`" umgewandelt worden sind.

__________________
Viele Grüße,
Dennis Gruß
11.07.2005 10:56 idnet ist offline E-Mail an idnet senden Beiträge von idnet suchen Nehme idnet in Deine Freundesliste auf
Baumstruktur | Brettstruktur
Gehe zu:
Neues Thema erstellen Antwort erstellen
pdadmin-forum » Information » Add-On Diskussionen » AddOn: Uptime (PDA Admin-Bereich)

Impressum | Team | Hilfe

Forensoftware: Burning Board, entwickelt von WoltLab GmbH    |    Design entwickelt von You-Online.de