TYPO3 Addon: Interner Serverfehler

  • Hallo!


    Eine ganze Weile hat das Addon gute Dienste geleistet aber nun nach einiger Zeit ohne Benutzung kommt ein Internal Server Error. Das Log apache/error.log zeigt an:
    reseller.pl: /opt/pdadmin/nav/firsthbn/administraror_menu.conf: Permission denied/administrator/addon.typo3.cgi
    LATEST_PDADMIN: Permission denied at PERL2EXE_STORAGE/CGI/Carp.pm line 314./addon.typo3.cgi
    [Tue Dec 5 00:44:00 2006] [error] [client 84.183.185.248] Premature end of script headers: /opt/pdadmin/www/administrator/administrator.cgi
    DBD::mysql::st execute failed: Unknown column 'vhosts.domain' in 'on clause' at /opt/pdadmin/www/administrator/addon.typo3.cgi line 89.
    cannot execute query 'SELECT vhosts.name, vhosts.id, vhosts.target, domains.name FROM vhosts, sessions, users LEFT JOIN domains ON domains.id = vhosts.domain WHERE sessions.session = 'bfb274452d5c98f47499cebcf4494b26c68e' AND sessions.user = users.reseller AND domains.owner = users.id AND vhosts.name NOT LIKE '' ' at /opt/pdadmin/www/administrator/addon.typo3.cgi line 89.
    [Tue Dec 5 00:44:02 2006] [error] [client 84.183.185.248] Premature end of script headers: /opt/pdadmin/www/administrator/addon.typo3.cgi



    Zunächst weiß ich nicht, wo administraror_menu.conf herkommt, sollte ja eigentlich administrator_menu.conf heißen. Anlegen der Datei und kopieren der eigentlich gemeinten ändert aber nichts.
    Die tabelle vhosts.domain existiert und beinhaltet Daten.


    Freue mich über Hilfe jeder Art,


    Markus

  • Es fehlt das Suid bit von der addon.typo3.cgi, bei dem letzten Update von Pd-Admin wird das wohl rausgenommen oder so ^.^.


    Ist bei mir letztens auch aufgetretten.


    Aber es freut mich zu hören das jemand mein Addon benutzt :-) *freu*.



    Grüße


    Michael.

    Entwicklung von Addons wieder aufgenommen trotz Compelierten Perl Dateien.

  • Hallo Michael,
    das setuid-bit war bereits gesetzt. An diesem scheint es nicht zu liegen:
    -rwsr-xr-x 1 root root 8225 2006-09-22 17:37 addon.typo3.cgi


    -rw-r--r-- 1 root root 3975 2006-09-22 11:58 addon.typo3.main.html
    -rw-r--r-- 1 root root 3346 2005-11-15 20:22 addon.typo3.status.html


    Woran kann es denn noch liegen? Grüße,
    Markus


    PS: ich habe MySQL auf Version 5 geupdated. Kann es daran liegen?

  • Mmmh das ist echt seltsam.


    Ähm eine frage setzt du die SE ein ?


    Weil mein Addon ist so geschrieben das es mit der SE von PD-Admin problemlos arbeitet.


    Denn wie hast du sonst die MYSQL Version auf 5 geupdatet ?

    Entwicklung von Addons wieder aufgenommen trotz Compelierten Perl Dateien.

  • Hi,


    ich nutze das Standardpaket, dass bei meinem Provider firsthop dabei war. Ich gehe davon aus, dass es die SE ist. pd-admin zeigt Version v3.x an.


    Das Update habe ich über die Konsole mit apt-get gemacht.


    Grüße,
    Markus


  • Firsthop setzt NICHT die SE ein. Zumindest bis vor ein paar Tagen haben die noch eine eigene Umgebung aufgesetzt. Und ich denke nicht, dass die dies geändert haben.



    Ich würde empfehlen das minimal Image aufzusetzen und den Rest selbst zu machen. Bei Fragen hierzu, aber bitte neues Thema aufmachen.

  • Man sollte mal überlegen einen Hinweis zu zu pinnen in der Art "Firsthop Kunde? Wenden Sie sich bitte an deren Support die leider keine Standardumgebung eingesetzt wird." ;) Ist ja schon auffällig das hier immer mal wieder Kunden mit "Problemen" kommen die gerne mit der fehlenden SE zu tun haben. ;)


    Das Kunden/Admins z.b. MySQL selbst per APT einspielen wiederspricht ja Imho ein wenig dem Ansatz von PD-Admin.

  • naja, dafür hat man halt einen dedizierten Server, um selbst volle Kontrolle über die Installierten Programme zu haben.
    Tatsache war, dass das Addon bei mir trotz aufgebohrter Firsthop-Software funktioniert hat. Einwandfrei sogar. Doch inzwischen eben nicht mehr...
    Vielleicht schreibe ich ein kleines Skript für Firsthop-Kunden.


    Grüße,
    Markus

  • [Edit]
    Eine frage kann es sein das bei dir auf dem Server 2 Mysql Dienste laufen?
    [/Edit]


    Ich werde mal Firsthop anschreiben wie Sie die Serverumgebung konfiguriert haben, vielleicht sagen Sie es mir ja und ich kann das Script soweit anpassen das es auch wieder bei dir leuft.


    Grüße


    Michael.

    Entwicklung von Addons wieder aufgenommen trotz Compelierten Perl Dateien.

  • Zitat

    Original von Michael
    [Edit]
    Eine frage kann es sein das bei dir auf dem Server 2 Mysql Dienste laufen?
    [/Edit]


    Hmm, nicht dass ich wüsste. Wieso denkst du das?


    ja, schreib die gerne mal an. Mal sehen, was passiert.


    Gruß,
    Markus

  • Also hier ist mal die nette antwort von Firsthop


    Zitat

    Das Image ist im Endeffekt ein Originalaufbau wie PD-ADMIN früher regulär
    ausgeliefert wurde.


    Im Endeffekt eine Standard Debian Installation mit normaler PD-ADMIN Setup
    Ausführung wobei ein Update von Version 2.X auf Version 3.X nachträglich
    durchgeführt wurde.


    Ok wie wurde PD-Admin damals ausgeliefert ?

    Entwicklung von Addons wieder aufgenommen trotz Compelierten Perl Dateien.

  • Zitat

    Original von Michael
    Also hier ist mal die nette antwort von Firsthop



    Ok wie wurde PD-Admin damals ausgeliefert ?


    Naja ich kenne PD-ADMIN von der ersten Version an und damals wurde es so wie es hier schon einige beschrieben haben mit manueller Installation von MySQL, PHP etc. installiert.


    Ich persönlich halte nichts von der SE und nutze halt eher die Möglichkeit der manuellen Installation.


    Gruß
    Sid