SMTP Problem: Keine Annahne von Mails und auch kein Senden möglich

  • - Welche Version von pd-admin wird eingesetzt? 4.24
    - Welche Version der Serverumgebung wird eingesetzt? 4-0.273


    Bei einem Server werden auf einmal keine Mails mehr angenommen und ein Versenden über SMTP (z.B. über Roundcube) ist auch nicht möglich.


    Fehlermeldung auf dem Remote Mailserver, der Mails zustellen möchte:

    Code
    1. lost connection with mail.server.tld[12.34.56.78] while receiving the initial server greeting


    Fehlermeldung (in daemon.log) auf dem lokalen Mailserver, der die Mails annehmen soll:

    Code
    1. smtpd: 1470536778.545344 exec failed at /usr/sbin/relaylock line 81.
    2. smtpd: 1470536778.545565 tcpserver: end 4703 status 512


    Eine qmail Logdatei gibt es nicht, wo eventuell Fehler genauer beschrieben sein könnten. Geändert hat sich an dem System nichts. Keine Ahnung warum sich tcpserver auf einmal so verhält.


    Neu starten von qmail hat nichts gebracht.


    Die Dienste sind alle aus der Standard Serverumgebung.


    Im Log von Roundcube finde ich auch nur das:

    Code
    1. SMTP error: Connection failed: Invalid response code received from server


    In der Shell kann ich allerdings via "mail" Nachrichten senden.


    Hatte das schonmal jemand und hat Tipps, wie ich den Mailserver wieder zur Arbeit bewege?


    Dankeschön!

  • Dienste laufen, wurden auch nochmal vorsichtshalber neu gestartet.
    Festplatte hat noch 60GB frei.



    ...


    Aber ich hab den Fehler jetzt gefunden! Aus irgend einem Grund war /var/qmail/bin/rblsmtpd nicht mehr vorhanden! Nachdem ich die Datei wiederhergestellt habe, läuft alles wieder.