Debian 9 "Stretch" mit PD Admin

  • Hallo zusammen,

    bei uns wird es Zeit aus zwei alt gedienten Proliant-Servern einen neuen zu machen ....


    Hat von euch schon jemand Debian 9 für PDA genutzt und wenn ja, gibt es Erfahrungswerte für die Installation?


    Danke im Voraus,


    Sascha

  • Ich habe es schon einmal testweise installiert und es scheint zu laufen.
    Ich bevorzuge selber mittlerweile eigentlich CentOS, da hat man einfach länger Ruhe bis es dort einen neuen Release gibt.
    Denn pd-admin bringt ja eigentlich alle Dienste selber mit und braucht nur eine stabile Plattform.

  • Tut soweit ohne Probleme. Lasse ich schon länger laufen.


    Folgende Pakete brauchst du:


    Debian etch/lenny/squeeze/wheezy/jessie: g++ gcc imagemagick lib32ncurses5 lib32stdc++6 lib32z1 libc6-dev-i386 make patch psmisc rrdtool :D

  • Das hört sich ja schon mal positiv an :-)


    PDA wird ja, wenn ich es richtig in Erinnerung habe, auch auf CentOS bei B&K entwickelt und eingesetzt. Bringt mich natürlich dann auch auf den Gedanken ein OS Wechsel in Betracht zu ziehen.


    Welche Unterschiede/Vorteile würdet ihr aufgrund euer Erfahrung sehen??


    Wäre schon sehr interessant , so rein aus Admin Sicht....


    Danke und Gruß,
    Sascha

  • Du hattest geschrieben, das würde bei dir schon länger laufen und nun schränkst du ein das login würde nicht funktionieren...


    jetzt bin ich verwirrt ;-)


    Debian würde ich aufgrund meiner Erfahrungen bevorzugen, lasse mich aber gern, wenn es Vorteile bringt, von CentOS überzeugen.


    Ist der Umstieg auf ein RedHat Derivat für uns Admins "simpel" oder fühlt es sich an als würde man wieder auf der "grünen Wiese stehen" ?


    Gruß,
    Sascha

  • Also ich komme ursprünglich mal aus der Schiene von Digital Unix und wer sich mit Linux/Unix auskennt sollte eigentlich bei jeder gängigen Distribution keine großen Probleme haben,
    da die Grundbefehle ja immer gleich sind und pd-admin ja eigentlich auch fast alles selber mitbringt in seiner Serverumgebung.
    Bei CentOS gibt es halt eine andere Paketverwaltung, was jetzt aber auch nicht zu großen Problemen führen dürfte.

  • Hmmm, bis auf die Paketverwaltung sollte es damit ja recht identisch sein...
    So richtig überzeugte Meinungen im Sinne von "Jaaaaa, CentOS!" oder "Debian auf jeden Fall" waren ja nun nicht dabei....


    Mit den aktuellsten Debian gab es immer mal wieder "Haker" und man musste schon bewusst testen. Ist das mit CentOS ebenso gewesen ?


    Danke und Gruß,
    Sascha

  • Ich habe mit Debian keine großen Erfahrungen, daher kann ich das schwer beurteilen. pd-admin habe ich immer mit CentOS benutzt und im Betrieb keine "Haker" gehabt. Bei meinen letzten Installationen auf CentOS 7 war Postfix vorinstalliert. Dies musste entfernt werden, da es sonst zur Störung beim Maildienst kam. Sonst klappte alles problemlos.

  • Also ich habe jetzt alle Server auf CentOS laufen, allerdings hatte ich mit Debian auch nicht wirklich Probleme. Da ich alle Server virtuell betreibe habe ich mich für CentOS entschieden, da Debian ja früher noch alle 2-3 Jahre geupdatet werden musste und heute ja auch "nur" 5 Jahre gepflegt wird und CentOS halt 10 Jahre und ich die Server so einfach lange laufen lassen kann. An Deiner Stelle würde ich mir CentOS einfach mal anschauen und dann kannst Du ja selber entscheiden, welche Distribution Du nehmen willst.

  • Zitat

    Original von Blueroot
    Achtung: Bei mir geht der Login bei pd-admin 4 nicht mit Debian 9. Es kommt immer ein "internal server error" ohne weitere Infos in der Log.


    Hallo, wie hast du den Fehler gelöst?


    Bei mir erscheint im error_log dieser Fehler:

    Code
    Premature end of script headers: administrator.cgi,
  • v4.57
    SE 4-0.298


    Wir haben nun auch den ersten Debian9.2 mit PD-Admin versucht...


    Mit dem Ausdokumentieren der IPv6 in /etc/hosts geht das Backend erstmal.
    Mein Problem ist das in der run-Datei für qmail-smtpd ein Host fest drin steht der nicht meiner ist...


    Ich bekomme beim Versuch mails dort hin zu senden immer:


    (1) Connecting to server xx.xx.xx.xx on port 25
    (1) Connection established (968)
    (1) 421 unable to read controls (#4.3.0)
    (1) SMTP Server: Not ready!
    (1) Mail Transmission aborted


    Irgendwie schauen auch die runfiles anders aus als auf anderen pd-admins
    Auch war der symlink zu sendmail nicht gesetzt und der squirrelmail lässt sich mit apache24 nicht auf deutsch bringen. obwohl ich schon locales reconfiguriert habe etc.


    Ich bin da irgendwie unsicher ob da nicht was total gedreht ist...


    Meine Vorgehensweise auf ein Debin92 minimal-System:


    apt-get install lftp iftop patch make psmisc zip imagemagick gcc g++ libc6-dev-i386 lib32stdc++6 lib32ncurses5 lib32z1 rrdtool


    wget www.pd-admin.de/download/pdadmin_v4.tar.gz
    apt-get install whois
    apt-get install imagemagick
    apt-get update
    apt-get upgrade
    tar zxPvf pdadmin_v4.tar.gz
    apt-get install locales
    dpkg-reconfigure locales
    reboot
    ./install-all.sh
    /opt/pdadmin/bin/create_reseller.pl "Manfred Onderka"
    reboot


    wget http://download.pd-admin.de/dc-ssl-install.sh
    cd /opt/pdadmin/sslcerts/
    cp 2016_STAR.onitdomain.de-* .
    mv 2016_STAR.onitdomain.de-cacert server0x.onitdomain.de-cacert
    mv 2016_STAR.onitdomain.de-cert server0x.onitdomain.de-cert
    mv 2016_STAR.onitdomain.de-key server0x.onitdomain.de-key
    /opt/pdadmin/bin/httpd_vhosts.pl
    cd
    chmod 755 dc-ssl-install.sh
    ./dc-ssl-install.sh


    /opt/pdadmin/bin/get_license.sh
    apt-get install lftp
    apt-get install smartmontools
    dpkg -i --force-all /usr/local/pd-admin2/SPECIAL/mta-dummy_1.0_all.deb;
    aptitude purge $(dpkg -l exim4* |grep ^ii |awk '{print $2}' |tr '\n' ' ')
    reboot


    cd /var/qmail/bin/
    ./config-fast server0x.onitdomain.de



    In der /usr/src/service3r.tar.gz sind die Runfiles und da sind fest verdrahtete Hosts und IDs drin. Die habe ich dann nochmal manuell an die Daten eines alten PD-Admins angepasst. Aber fast alle Runfiles auf 6 verschiedenen Servern sind unterschiedlich.


    apache24
    Hier wird, so ist das zumindest aktuelle beobachtet, nicht immer zuverlässig eine neue access_log Datei nach dem rotieren angelegt. Die Daten werden dann in eine mit suffix Zeitstempel eingetragen. Soll das so sein?



    Das soll ein bisschen als Howto dienen und ggf. kann mir jemand mit qmail und squirrelmail einen Tipp geben..


    Manfred



    [Update]
    ich habe in dem runfile qmail-smtpd/run mit hostname -f und die beiden owner und group-ids dynamisch eingetragen und jetzt geht es (früher war das bei der Installation mal automatisch).


    Außerdem ist nach wie vor das servercert.pem in /var/qmail/control defekt weil ein Zeilenumbruch zwischen zertifikat und CA-Zertifikaten nicht korrekt ist.
    Manuell ändern und service/qmail-smtpSd neu starten behebt auch das


    Seltsamerweise ist das auch die erste Installation die eine my.cfg in /etc/ hat die irgendwo in alternate.d zeigt ohne das ein anderer mysql als der vom pdadmin drauf ist.
    Um ein SE-Update zu machen muss das auf /usr/local/pdadmin2/etc/my.cfg symlinked werden.