Can't load driver file apr_dbd_mysql.so

  • Dies ist eine vorgefertigte Schablone, die bei der Formulierung von Problemen unterstützen soll. Bitte die folgenden Angaben möglichst vollständig ausfüllen.


    - Welche Version von pd-admin wird eingesetzt? 4.56
    - Welche Version der Serverumgebung wird eingesetzt? 0.298
    - Welche Fehlermeldung erhalten Sie? s.u.


    Code
    Can't load driver file apr_dbd_mysql.so


    Wäre es möglich, dass die SE die Datei apr_dbd_mysql.so, apr_dbd_sqlite3.so, apr_dbd_pgsql.so und evtl. apr_dbd_odbc.so mitliefert?


    mfg
    Twilo

  • Hallo,


    https://httpd.apache.org/docs/2.4/mod/mod_authn_dbd.html


    1. z.B. folgendes in der Datei /usr/local/pd-admin2/httpd-2.4/conf/httpd24.conf-template hinzufügen

    Code
    <IfModule mod_authn_dbd.c>
    # mod_dbd configuration
    DBDriver mysql
    DBDParams "host=localhost,port=3306,dbname=NNNNN,user=UUUUU,pass=PPPPP"
    DBDMin 1
    DBDKeep 2
    DBDMax 10
    DBDExptime 300
    DBDPersist Off
    </IfModule>


    2.
    bei einen VirtualHost folgendes hinzufügen lassen, z.B. mit addon_additionalVhostLine (damit können zusätzliche Zeilen bei VirtualHosts hinzugefügt werden)

    Code
    <Directory "/home/USER/DOMAIN/">
    AuthType Basic
    AuthName "AA BB CC"
    AuthBasicProvider dbd
    AuthDBDUserPWQuery "SELECT _pass FROM FFFFF WHERE _user COLLATE latin1_general_cs like %s
    Require valid-user
    </Directory>


    3. Apache 2.4 auswählen


    ich hoffe, dass ich nichts vergessen habe



    EDIT: ich sehe gerade, dass ich das Addon addon_additionalVhostLine nicht freigegeben habe; kann ich bei Bedarf zur Verfügung stellen
    Besser wäre, wenn pd-admin soetwas schon von Hause aus unterstützt ;-)


    mfg
    Twilo