Dienste starten nach SE-Update nicht

  • Hallo,

    Ich hab die SE geupdatet. Nach dem stoppen der Dienste ging es nicht mehr weiter. Ich hab dann einen Neustart gemacht und das Update nochmal versucht. Er sagt es ist die aktuelle Version installiert. Nur die Dienste scheinen nicht gestartet zu sein.


    Nun hab ich folgende Fragen:

    Wie starte ich einen Dienst?

    Welche Dienste muss ich alles starten?

    Wie verhindere ich das es beim nächsten Update wieder passiert?

  • Die Dienste liegen unter /services/ gestartet werden kann ein Dienst mit z.b.

    Code
    1. svc -u /services/qmail-smtpSd

    Die Frage ist halt nur, warum die Dienste nach dem Update nicht korrekt gestartet wurden. Findet sich etwas in den Logs?


    Ich habe das Update heute auch durchgeführt und da lief alles problemlos.

  • Ich vermute das das Update mittendrin abgebrochen wurde.


    Gibt es eine Möglichkeit es erneut zu installieren? Wenn ich die übliche Methode anwende, wird mir gesagt das es schon aktuell ist. Also bräuchte ich irgendwas ohne Versionsüberprüfung

  • Code
    1. /service/apache24: up (pid 16318) 1 seconds
    2. /service/clamd: up (pid 722) 6778 seconds
    3. /service/dovecot22: up (pid 16317) 1 seconds
    4. /service/mysqld: up (pid 724) 6778 seconds
    5. /service/proftpd: up (pid 731) 6778 seconds
    6. /service/qmail-msa: up (pid 728) 6778 seconds
    7. /service/qmail-send: up (pid 729) 6778 seconds
    8. /service/qmail-smtpd: up (pid 732) 6778 seconds
    9. /service/qmail-smtpSd: up (pid 703) 6778 seconds
    10. /service/spamd: up (pid 723) 6778 seconds
  • Debian nutze ich. Neu gestartet habe ich.


  • Code
    1. PHP Warning: array_filter() expects parameter 1 to be array, string given in /home/dasmadb9/www.dasmaerchenvombilligenfuehrerschein.de/wp-content/plugins/pie-register/pie-register.php on line 664
    2. PHP Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /home/dasmadb9/www.dasmaerchenvombilligenfuehrerschein.de/wp-content/plugins/pie-register/classes/profile_front.php on line 88
    3. PHP Warning: Use of undefined constant ?AUTOMATIC_UPDATER_DISABLED? - assumed '?AUTOMATIC_UPDATER_DISABLED?' (this will throw an Error in a future version of PHP) in /home/dasmadb9/www.dasmaerchenvombilligenfuehrerschein.de/wp-config.php on line 93
    4. PHP Warning: array_filter() expects parameter 1 to be array, string given in /home/dasmadb9/www.dasmaerchenvombilligenfuehrerschein.de/wp-content/plugins/pie-register/pie-register.php on line 664
    5. PHP Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /home/cstrodbh/www.c-strothmann.de/wp-includes/pomo/plural-forms.php on line 210
    6. PHP Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /home/cstrodbh/www.c-strothmann.de/wp-content/plugins/pie-register/classes/profile_front.php on line 88
    7. PHP Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /home/cstrodbh/www.c-strothmann.de/wp-includes/pomo/plural-forms.php on line 210
    8. PHP Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /home/cstrodbh/www.c-strothmann.de/wp-content/plugins/pie-register/classes/profile_front.php on line 88
    9. PHP Warning: array_filter() expects parameter 1 to be array, string given in /home/cstrodbh/www.c-strothmann.de/wp-content/plugins/pie-register/pie-register.php on line 647
    10. [Mon Dec 17 20:01:58.572412 2018] [mpm_prefork:notice] [pid 718] AH00169: caught SIGTERM, shutting down
  • Soweit ich der netstat Ausgabe entnehmen kann, läuft lediglich der Webserver nicht. Die restlichen Dienste offenbar schon. Das wird einen Grund haben, warum der nicht hoch kommt.


    Schau mal in die Prozessliste mittels "ps aux" ob da httpd Prozesse laufen. Vermutlich nicht.


    Dann würde ich an Deiner Stelle mal händisch den apache neu starten. Deinen Ausgaben entnehme ich, dass Du apache2.4 einsetzt, also probier folgendes:


    zuerst sicherheitshalber:

    /usr/local/pd-admin2/httpd-2.4/bin/apachectl stop


    Anschließend

    /usr/local/pd-admin2/httpd-2.4/bin/apachectl start


    Achte darauf ob es hier irgendwelche Ausgaben gibt und check danach nochmal /usr/local/pd-admin2/logs/error_log