Drupal 8 und PHP7.3

  • Hallo!

    Mein Problem ist das Drupal 8. gerne die PHP7.3 nutzen möchte. Die PHP 7.3 ist auch aktiviert (Admin und User), nur scheint es der APS-Installer nicht zu bemerken. Er erkennt nur die alte PHP-Version.

    Leider kann ich deshalb Drupal 8 nicht installieren. Vielleicht kann mir jemand da mal einen Tipp geben. Die PDA-Version und SE ist die aktuellste 0.336.

    Lieben Dank

  • hatte ich bereits getan. die PHP 7.3.8 wird über phpinfo ausgegeben. Weshalb Drupal nun immer die 5er PHP-Version sieht...

    STDOUT: <PHP: 5.6.40

    Your PHP installation is too old. Drupal requires

    Bin ein wenig ratlos...


  • Zitat von tbc233

    Sieht verdächtig danach aus als würde der Installer hier die CLI Version prüfen. Hast Du diese schon hochgestellt?

    Wenn die CLI Version nicht angepasst wurde, ist diese 4.4.9 und nicht 5.6.X, da nämlich /usr/local/pd-admin2/bin/php genommen wird.

    Wenn es also keine Anpassungen der CLI gab, kann man dies hier als Fehler ausschließen.

    Zitat von eddy_belu

    [...] nur scheint es der APS-Installer nicht zu bemerken. Er erkennt nur die alte PHP-Version.

    Drupal wird per APS-Installer installiert. AFAIK wird der APS-Installer per PHP 5.6 ausgeführt. Daher wird wohl der Fehler kommen.

  • Hab nun so einiges ausprobiert, auch die Idee von Eisenherz jedoch greift der APS-Installer seltsamer Weise immer die 5.6. Vielleicht weiß jemand wo man an den Installerscript drehen kann, damit die korrekte PHP -v genommen wird? LG

  • Wenn ich das richtig sehe wird der Installer per customer.cgi ausgeführt. Da ich den bisher sonst nirgends gefunden habe, würde ich vermuten, ist dieser Teil der customer.cgi - und diese kompiliert und kann nicht einfach bearbeitet werden.