Ungültiger Domainname! bei Neuinstallation

  • Hallo,

    - neue Serverinstallation mit Debian 9 über BK Manager v2.

    - pdadmin und se installiert (v4.61 und 6-0.336)

    - pdadmin gestartet

    Nun wollte ich meine Domains die auch im BK Manager angelegt sind wieder auf meinem Cloudserver-50 anlegen. Angebot in pdadmin erstellt, Neue Domain/neuen Kunden einrichten --> alles entprechend ausgefüllt --> Fehlermeldung "Ungültiger Domainname!".
    alle Dienste laufen:
    /service/apache24: up (pid 450) 1453 seconds

    /service/clamd: up (pid 457) 1453 seconds

    /service/dovecot22: up (pid 453) 1453 seconds

    /service/mysqld: up (pid 454) 1453 seconds

    /service/proftpd: up (pid 445) 1453 seconds

    /service/qmail-msa: up (pid 455) 1453 seconds

    /service/qmail-send: up (pid 456) 1453 seconds

    /service/qmail-smtpd: up (pid 451) 1453 seconds

    /service/spamd: up (pid 449) 1453 seconds


    perl steht entsprechend auf pdadmin2, soweit alles bestens, woran kann das nur liegen?


    Solange ich keine Domain anlegen kann, kann ich keine Mailadresse einrichten und somit auch keine Mail an Bradler&Krantz senden ;(


    Bitte dringend um Unterstützung,

    Vielen Dank vorab,

    RudiX

  • ... na Klasse, hab den Fehler gefunden.

    in der pdadmin-Oberfläche unter Einstellungen --> Serverkonfiguration bei Erlaubte TLDs fehlte die erste eckige Klammer [a-z]{2,16}.

    Damit muss entsprechend auch in der pdadmin.conf der Eintrag @domains_allowed geändert werden!

    Da könnt ich grad Hörner kriegen! :saint:

    Jetzt funktionierts.


    Viele Grüße, RudiX

  • RudiX

    Hat das Label [erledigt] hinzugefügt
  • Danke, Rudix, auch diesen Fehler kann ich nachvollziehen.

    Ich habe vor puh >10 Jahren schon pd-admin gekauft und eine zeit nicht genutzt.

    Die ganzen Bugs bei der August 2019 Installation haben sich mehr gehäuft als in 10 Jahren PC Admin Nutzung.


    Edit nun genauso umgesetzt wie du geschrieben hast, dein Bugfix funktioniert.