sperl15.10.1 und diverse weitere Fehler, Debian 10 und Debian 9!

  • Hallo Zusammen


    Ich verwende Debian 10

    Installation mit pdadmin wirft diesen Fehler:


    Code
    1. ** suidperl wird erzeugt **
    2. chmod: cannot access '/usr/local/pd-admin2/bin/sperl5.10.1': No such file or directory
    3. + workaround for perl without suid support


    Zusätzlich, nachdem ich pd-admin installiere und das oben ignoriere kommt:


    apache fehlt im Verzeichnis /service


    mysql wird auch nicht korrekt eingerichtet:



    Edit:

    Natürlich sind die Pakete alle installiert, die der gute Twilo hier gepostet hat:

    Standardumgebung mit einem 64bit System


    Hat jemand eine Idee?

    Danke

  • Danke, Eisenherz das behebt aber nicht den sperl Fehler und die mysql Fehlermeldung.


    Habe das neue Script getestet, aber Apache funktioniert weiter nicht:

    Code
    1. Writing /usr/local/pd-admin2/conf/httpd.conf
    2. Writing /usr/local/pd-admin2/httpd-2.4/conf/httpd.conf
    3. webserver = <AP24>
    4. enabled apache24
    5. mv: cannot stat '/service/apache': No such file or directory
    6. httpd not running, trying to start
    7. httpd not running, trying to start
  • Edit:

    In Service gibt es nun das apache24 Verzeichnis sehe ich gerade, daher gehen die alten Scripte nicht.

    Apache läuft.



    Code
    1. ls -ld /service/apache*
    2. drwxr-xr-x 3 root root 4096 Aug 11 13:40 /service/apache24


    Dann besteht nur noch der sperl Fehler oben, sowie eine Todo der Anleitung die sich scheinbar geändert hat mit Debian 10.

  • Nach viel rumprobieren, und bugfixing, siehe oben


    Das Ganze läuft nicht rund mit Debian 10:


    /administrator läuft nun, aber leider nicht vollständig, ich kann Angebote erstellen, Reseller anlegen, aber keine Domains / Kunden.

    Bei Serverkonfiguration http://***/administrator/sid/*****/administrator.cgi?todo=preferences.server.print

    kommt auch Mist bei raus.


    Code
    1. Internal Server Error
    2. The server encountered an internal error or misconfiguration and was unable to complete your request.
    3. Please contact the server administrator at [x@x] to inform them of the time this error occurred, and the actions you performed just before this error.
    4. More information about this error may be available in the server error log.

    Error Log im pdadmin2 Verzeichnis:

    Code
    1. [Sun Aug 11 16:30:01.744227 2019] [core:notice] [pid 618] AH00094: Command line: '/usr/local/pd-admin2/httpd-2.4/bin/httpd -D NO_DETACH -D SSL'
    2. [Sun Aug 11 16:31:51.161330 2019] [cgid:error] [pid 3854] [client meine IP:40162] End of script output before headers: administrator.cgi, referer: http://server ip/administrator/sid/ae24505dd50c25c9c3d82375282c21
    3. [Sun Aug 11 16:31:53.768051 2019] [cgid:error] [pid 3859] [client meine IP:40081] End of script output before headers: administrator.cgi, referer: http://server ip/administrator/sid/ae24505dd50c25c9c3d82375282c21
    4. [Sun Aug 11 16:31:57.745277 2019] [cgid:error] [pid 3860] [client meine IP:40053] End of script output before headers: administrator.cgi, referer: http://server ip/administrator/sid/ae24505dd50c25c9c3d82375282c21
    5. [Sun Aug 11 16:32:09.289211 2019] [cgid:error] [pid 3852] [client meine IP:40035] End of script output before headers: administrator.cgi, referer: http://server ip/administrator/sid/ae24505dd50c25c9c3d82375282c21
    6. [Sun Aug 11 16:32:19.380867 2019] [cgid:error] [pid 3865] [client meine IP:40038] End of script output before headers: administrator.cgi, referer: http://server ip/administrator/sid/ae24505dd50c25c9c3d82375282c21
  • Hallo Zusammen,

    Hallo Daniel Bradler

    Debian 9 hat auch das sperl Problem:


    Code
    1. admin2/bin/sperl5.10.1': No such file or directory
    2. + workaround for perl without suid support


    /administrator/


    wirft auch nach Login diese Meldung:


    Code
    1. Internal Server Error
    2. The server encountered an internal error or misconfiguration and was unable to complete your request.
    3. Please contact the server administrator at [no address given] to inform them of the time this error occurred, and the actions you performed just before this error.
    4. More information about this error may be available in the server error log.


    und in der error.log steht folgendes:


    Code
    1. … [cgid:error] [pid 9280] [client 123.456.789.123:34426]
    2. End of script output before headers: administrator.cgi, referer: http://my.example.org/administrator/
  • Alan

    Hat den Titel des Themas von „sperl15.10.1 und diverse weitere Fehler, Debian 10“ zu „sperl15.10.1 und diverse weitere Fehler, Debian 10 und Debian 9!“ geändert.
  • Mit Debian 10 gibt es verschiedene Probleme. Es wird noch einige Zeit dauern, bis wir pd-admin angepasst haben.


    Bei Debian 9 ist mir als Problem nur bekannt, dass die IPv6-Eintraege aus /etc/hosts entfernt werden muessen.


    Die Fehlermeldung zu sperl5.10.1 duerfte mit der Version der Serverumgebung zusammenhaengen und ist nicht kritisch. Wir werden uns das Problem aber dennoch ansehen.

  • Bei Debian 9 ist mir als Problem nur bekannt, dass die IPv6-Eintraege aus /etc/hosts entfernt werden muessen.


    Danke für die Antwort, das läuft nun nachdem ich die ipv6 Einträge aus der /etc/hosts auskommentiert habe.



    hast du es auch mal Ubuntu-Server minimal versucht? Läuft hier in einer KVM-Umgebung sehr gut.


    ich würde lieber gern das "richtige" Debian statt Ubuntu nutzen.

    Eigentlich hätte ich gern Debian 10 gehabt.

  • ...

    ... bei mir läuft das mit den aktuellen SE und pdadmin-Versionen auch nicht unter Debian 9 !!!

    ... massive Probleme mit https den administrator-Zugang einzurichten, die SUB-Domains laufen nach einigen Nachinstallationen von dem ganzen Python-Paketen mit letsencrypt ! (aber erst nach langem Fehlersuchen!!!)

    ... das ist doch alles zum "Mäusemelken", jedesmal bei einer Neuinstallation unter Debian tagelange Fummelei,


    ... hätte Besseres zu tun, nächsten Montag gehe ich auf mehrtägige Radreise,

    ... da sollte das Ganze laufen,


    ... na ja, ist ebenso, der Kunde ist das TEST-PROJEKT ;(


    ... mach mich jetzt auch nicht bockig, gehe bald auf die 60 zu, hätte eben auch gerne noch einen stabilen Server mit aktueller Debian-Version und TYPO3 am laufen :*

    ... wäre schön, aber was nicht is, das is eben nicht.


    Gruß, RudiX

  • massive Probleme mit https den administrator-Zugang einzurichten, die SUB-Domains laufen nach einigen Nachinstallationen von dem ganzen Python-Paketen mit letsencrypt ! (aber erst nach langem Fehlersuchen!!!)

    Bei der erstmaligen Ausführung der certbot müssen python Pakete nachinstalliert werden. In Ihrem Beitrag schrieben Sie, dass Sie zunächst den Endkunde sudo-Berechtigungen geben mussten und dann Pakete manuell nachinstalliert haben. Dieses Verhalten ist mir neu und hatte ich bei Tests mit Debian und pd-admin noch nicht.


    Auch wenn es dadurch ein wenig Off-Topic wird... Wie sieht denn die Ausgabe von

    Code
    1. ls -al /opt/pdadmin/bin/certbot-auto*
    2. -rwxr-xr-x. 1 root root 57 27. Apr 2018 /opt/pdadmin/bin/certbot-auto
    3. -rwxr-xr-x. 1 root root 68689 9. Aug 15:59 /opt/pdadmin/bin/certbot-auto-o
    4. ls -al /opt/pdadmin/bin/letsencrypt
    5. -rwxr-xr-x. 1 root root 1518845 26. Jun 15:15 /opt/pdadmin/bin/letsencrypt

    aus?

  • root@vpscobra:~# ls -al /opt/pdadmin/bin/certbot-auto*

    -rwxr-xr-x 1 root www 68689 Aug 13 09:19 /opt/pdadmin/bin/certbot-auto


    und


    root@vpscobra:~# ls -al /opt/pdadmin/bin/letsencrypt

    -rwxr-xr-x 1 root root 1518845 Jun 26 15:15 /opt/pdadmin/bin/letsencrypt

  • Bei mir wurde bei erstmaliger Ausführung von /opt/pdadmin/bin/letsencrypt die certbot-auto Datei in certbot-auto-o umbenannt und /opt/pdadmin/bin/certbot-auto mit folgendem Inhalt angelegt:

    Code
    1. cat /opt/pdadmin/bin/certbot-auto
    2. #!/bin/bash
    3. exec /opt/pdadmin/bin/certbot-auto-o -q "$@"less /opt/pdadmin/bin/certbot-auto
    4. #!/bin/bash
    5. exec /opt/pdadmin/bin/certbot-auto-o -q "$@"

    Die Datei certbot-auto-o fehlt bei Ihnen.

  • ... es wird doch dann mit certbot-auto-o die umbenannte originale Datei verwendet?
    ... geht bei mir mit beiden certbot-auto und certbot-auto-o nicht

    ... ein Aufruf von /opt/pdadmin/bin/certbot-auto-o certonly --webroot -w /opt/pdadmin/etc/ssl-validation/ -d vpscobra.service4it.com


    bringt folgendenError:


    /opt/pdadmin/bin/certbot-auto-o certonly --webroot -w /opt/pdadmin/etc/ssl-validation/ -d vpscobra.service4it.com

    Saving debug log to /var/log/letsencrypt/letsencrypt.log

    Plugins selected: Authenticator webroot, Installer None

    Obtaining a new certificate

    Performing the following challenges:

    http-01 challenge for vpscobra.service4it.com

    Using the webroot path /opt/pdadmin/etc/ssl-validation for all unmatched domains.

    Waiting for verification...

    Challenge failed for domain vpscobra.service4it.com

    http-01 challenge for vpscobra.service4it.com

    Cleaning up challenges

    Some challenges have failed.


    IMPORTANT NOTES:

    - The following errors were reported by the server:


    Domain: vpscobra.service4it.com

    Type: unauthorized

    Detail: Invalid response from

    http://vpscobra.service4it.com…W0_1S1MS6zTVMT37J5Im060ak

    [185.13.148.168]: "<!DOCTYPE HTML PUBLIC \"-//IETF//DTD HTML

    2.0//EN\">\n<html><head>\n<title>404 Not

    Found</title>\n</head><body>\n<h1>Not Found</h1>\n<p"


    To fix these errors, please make sure that your domain name was

    entered correctly and the DNS A/AAAA record(s) for that domain

    contain(s) the right IP address.


    Muss da jetzt evtl. vorher der RedirectMatch rein?

    RedirectMatch ^(?!/\.well-known/acme-challenge).* https://$$SERVERNAME$0


    EIn erneuter Aufruf endet nun so:

    Saving debug log to /var/log/letsencrypt/letsencrypt.log

    Plugins selected: Authenticator webroot, Installer None

    Obtaining a new certificate

    An unexpected error occurred:

    There were too many requests of a given type :: Error creating new order :: too many failed authorizations recently: see https://letsencrypt.org/docs/rate-limits/

    Please see the logfiles in /var/log/letsencrypt for more details.