Exchange 2019 unter Windows 10

  • Hallo,


    hat hier schon jemand Exchange 2019 unter Windows Server 2019 so zum Laufen bekommen, dass Exchange über pdadmin (qmail mit TLS required) Mails versenden kann.


    Vorher lief ein Exchange 2010 (auf 2018R2) und da funktionierte es.


    Nach dem Versuch eine Mail zu versenden, erscheint dort

    Code
    1. [{LED=451 4.4.395 Target host responded with error. -> 421 4.4.1 Connection timed out};{MSG=};{FQDN=x.example.com};{IP=123.0.0.123};{LRT=26.08.2019 09:10:49}]

    Wenn das TLS Häkchen in Exchange entfernt wird, erscheint die Meldung, das TLS benötigt wird.


    Woran kann das liegen?

  • Hallo,


    vielen Dank.


    Gibt es noch eine weitere Log, außer /var/log/mail.log?

    Wenn die TLS Option im Exchange aktiviert wurde, sehe ich in der mail.log keinen Eintrag. Wo werden die TLS Einträge geloggt?


    Im qmail-smtpd run-File habe ich folgendes hinzugefügt:

    Code
    1. export FORCETLS=1
  • Beitrag von Twilo ()

    Dieser Beitrag wurde vom Autor gelöscht ().
  • Hallo,


    was bedeutet folgende Zeile?

    Code
    1. TLS negotiation failed with error IllegalMessage
  • Ehrlich gesagt wundert es mich, dass Du mit diesem Setup durchgekommen bist, ohne dass bei Dir rund um die Uhr das Telefon läutet. Also jedenfalls dann, wenn auf dem betroffenen Server schon einige Mailboxen laufen. Insbesondere Apple (inkl. iphone etc.) ist bei sowas extrem empfindlich. Wenn da der Hostname aus dem Dialog nicht mit dem Zerti zusammenpasst, hagelt es ständig Warnungen die sich in neueren ios Versionen nicht mehr dauerhaft abnicken lassen.


    Unbeschadet dessen: Ich würd mal probieren was passiert, wenn Du ein Zerti verwendest dass beide Hostnamen mit drin hat. Dank letsencrypt kann man das ja recht leicht mal kostenlos antesten. Im Falle von certbot zum Beispiel einfach mal alle benötigten Hostnamen mit -d verfüttern.


    Wenn das geht, wärst Du fein raus.

  • bisher hat sich noch kein Kunde beschwert :/


    jetzt meldet sich der Mail-Server mit mail.example.org, der Exchange macht trotzdem zicken …


    weiß jemand, was folgende Logzeile bedeutet?

    Code
    1. 2019-09-06T07:01:05.112Z,XXX Smarthost,AAAAAAAAAAAAAAA,8,192.168.XXX.XXX:10959,178.63.XXX.XXX:25,*, CN=EX1 CN=EX1 DDDDDDDDD EEEEEE 2019-08-22T13:33:35.000Z 2024-08-22T13:33:35.000Z EX1;EX1.example.local,Sending certificate Subject Issuer name Serial number Thumbprint Not before Not after Subject alternate names

    versucht der Client ein Zertifikat zu senden?