ProFTPd fehlt

  • Hallo,

    ich habe eine VM mit OpenSuSE 42.2 und pd-admin 4.61 mit SE 4.0.339. Der Webserver und die darauf befindlichen Seiten laufen einwandfrei.

    Nun wollte ich FTP-Konten für zwei Kunden anlegen, was problemlos funktioniert.

    Ich kann nur keinen FTP-Server finden!

    ps -ax liefert mir proftpd [defunct], was immer das bedeutet.

    svc -d und -u /service/proftpd laufen ohne Fehlermeldung durch

    Aber: es gibt nirgends die Konfigurationsdatei von ProFTP, sollte die nicht /etc/proftpd.conf heissen?

    Es gibt auch kein Verzeichnis /etc/proftpd ...

    Was fehlt hier?

    Wie kann ich das wiederherstellen?

    Das Skript zum Umschalten auf pureftp habe ich auch probiert, das läuft auf einen Berechtigungfehler, den ich nicht auflösen kann.


    Danke für jeden Tipp.

    - Philipp

  • Hallo Eisenherz,

    danke für den Hinweis, das habe ich jetzt zum Laufen gebracht.

    Allerdings kann ich mich mit dem Server nicht richtig verbinden, ich gebe Benutzernamen und Kennwort ein, werde verbunden und dann bleibt der FTP-Client stehen ("Kann Verzeichnis nicht auflisten") und läuft auf einen Timeout.

    Es läuft kein weiterer Dienst auf Port 21.


    - Philipp

  • Es lag an der Konfiguration von ProFTP, nicht an der Firewall davor, mit einem NAT ist er nicht so glücklich.

    Ich musste mit einem MasqueradeAddress (externe IP Adresse) und einem PassivePorts 60000 60100 nachhelfen.

    Jetzt flutscht es.

    Abschliessend würde ich nur gern wissen, wie ich dem pdamin Host selbst SSL für seine Dienste beibringe, also auch für den ProFTPd.


    - Philipp