Neue Test-Version für Debian 10 x86_64

  • Installation verlief unter Debian 10.3 ohne Probleme, beim Aufruf von http://IP/administrator erhalte ich jedoch folgende Meldung:

    Code
    Forbidden
    You don't have permission to access this resource.Server unable to read htaccess file, denying access to be safe

    OK, Problem war bzw. ist, dass bei der Option --unattended die IP aus der /etc/hosts Datei genommen wurde und dort standen bei mir nur folgende Einträge

    Code
    127.0.0.1 localhost
    127.0.1.1 debian.local debian

    Müssen die IPv6 Einträge immer noch entfernt werden?



    ps. folgendes ist mir noch aufgefallen

    Code
    root@debian:~/pdadmin# /opt/pdadmin/www/customer/customer.cgi --version
    [Thu Feb 20 10:05:57 2020] customer.cgi: Use of uninitialized value in lc at /opt/pdadmin/www/customer/customer.cgi line 269.
    pd-admin version v4.63
    (c) 1999 - 2016 by Daniel Bradler
    1. Use of uninitialized value in lc
    2. das Jahr im Copyright ist auch schon etwas her ;)
  • Code
    customer.cgi: Use of uninitialized value in lc at /opt/pdadmin/www/customer/customer.cgi line 269.
    administrator.cgi: Use of uninitialized value in lc at /opt/pdadmin/www/administrator/administrator.cgi line 351.
    administrator.cgi: Argument "0.00:/images/diagram/gelb_vertikal.gif#/images/diagram/r..." isn't numeric in addition (+) at PERL2EXE_STORAGE/pd_diagram_v5.pm line 96.
    administrator.cgi: todo = <customers.main> action = <customers.domains.create> extra_param <1> disp = <customers.domains.create.html> at /opt/pdadmin/www/administrator/administrator.cgi line 2613.

    von den ersten beiden sind etliche Logeinträge vorhanden …

  • Code
    administrator.cgi: todo = <subresellers.main> action = <preferences.menu.create> extra_param <Neuer Eintrag> disp = <preferences.menu.change.html> at /opt/pdadmin/www/administrator/administrator.cgi line 2614.



    in der syslog Log erscheint folgendes

    Code
    Feb 26 17:42:50 debian proftpd: 2020-02-26 17:42:50,875 debian proftpd[5380]: fatal: unable to read configuration file '/usr/local/pd-admin2/etc/proftpd.conf': No such file or directory
    Feb 26 17:42:50 debian dovecot-log: 1582735370.881246 Fatal: Error reading configuration: stat(/usr/local/pd-admin2/dovecot-2.2/etc/dovecot/dovecot.conf) failed: No such file or directory
    Feb 26 17:42:51 debian proftpd: 2020-02-26 17:42:51,928 debian proftpd[5384]: fatal: unable to read configuration file '/usr/local/pd-admin2/etc/proftpd.conf': No such file or directory
    Feb 26 17:42:51 debian dovecot-log: 1582735371.931439 Fatal: Error reading configuration: stat(/usr/local/pd-admin2/dovecot-2.2/etc/dovecot/dovecot.conf) failed: No such file or directory
    Feb 26 17:42:52 debian proftpd: 2020-02-26 17:42:52,954 debian proftpd[5388]: fatal: unable to read configuration file '/usr/local/pd-admin2/etc/proftpd.conf': No such file or directory
    Feb 26 17:42:52 debian dovecot-log: 1582735372.956663 Fatal: Error reading configuration: stat(/usr/local/pd-admin2/dovecot-2.2/etc/dovecot/dovecot.conf) failed: No such file or directory
    Feb 26 17:42:53 debian dovecot-log: 1582735373.948592 Fatal: Error reading configuration: stat(/usr/local/pd-admin2/dovecot-2.2/etc/dovecot/dovecot.conf) failed: No such file or directory
    Feb 26 17:42:53 debian proftpd: 2020-02-26 17:42:53,956 debian proftpd[5412]: fatal: unable to read configuration file '/usr/local/pd-admin2/etc/proftpd.conf': No such file or directory
    Feb 26 17:42:54 debian dovecot-log: 1582735374.970385 Fatal: Error reading configuration: stat(/usr/local/pd-admin2/dovecot-2.2/etc/dovecot/dovecot.conf) failed: No such file or directory
    Feb 26 17:42:54 debian proftpd: 2020-02-26 17:42:54,980 debian proftpd[5454]: fatal: unable to read configuration file '/usr/local/pd-admin2/etc/proftpd.conf': No such file or directory

    ein ls ergibt jedoch, dass es die Datei gibt :/

    Code
    root@debian:~/pdadmin# ls -l /usr/local/pd-admin2/etc/proftpd.conf /usr/local/pd-admin2/dovecot-2.2/etc/dovecot/dovecot.conf
    -rw-r----- 1 root popuser 4424 Sep 7 2015 /usr/local/pd-admin2/dovecot-2.2/etc/dovecot/dovecot.conf
    -r-------- 1 root root 1826 Feb 26 17:42 /usr/local/pd-admin2/etc/proftpd.conf
  • der Aufruf von /opt/pdadmin/bin/httpd_log.pl dauert ewig

    warum dauert getpid() 1 Minute? :/


    Liegt es evtl. daran, weil noch keine Kunden/Domains eingerichtet wurden?

  • Lege ich zu einem vorhanden Kunden eine Domain an, dann werde ich auf eine nicht vorhandene Seite weitergeleitet.

    (Endkunden-Übersicht -> jeweiliger Endkunde -> Domains -> Neue Domain -> Status Domaineinrichtung -> Fehler "Keine Vorlagen gespeichert" )


    Ändere ich im Endkundenmenü die PHP-Einstellung einer Subdomain (CLI-Änderung sind nicht erlaubt und auf FPM eingestellt), dann ist die Subdomain nicht mehr erreichbar, Fehlermeldung im WWW (The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.)


    Logs:

    Code
    [Tue Mar 10 06:57:50.735723 2020] [proxy:error] [pid 18259] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /service/FPM-schwedbx-5.2.99/socket (*) failed
    [Tue Mar 10 06:57:50.735788 2020] [proxy_fcgi:error] [pid 18259] [client xx:46140] AH01079: failed to make connection to backend: httpd-UDS
  • Hallo,


    ich habe den zweiten Fehler beheben können, in dem ich in der run-File des Dienstes

    Code
    /service/FPM-schwedbx-5.2.99/run


    Den Wert "ulimit -u 256" gesetzt habe (Ursprünglich 64).

    Wie bekomme ich es hin, dass für alle neuen FPM Services die run-File automatisch wie oben gesetzt ist?


    Viele Grüße


    Tino

  • Wenn man in die man page von ulimit schaut:

    Code
    -u The maximum number of processes available to a single user.

    Dies sollte somit das Prozesslimit aus dem Angebot des Nutzers sein. Das Limit 64 ist imho schon sehr hoch. 256 wäre extrem hoch. 32 sollte als Standardwert ausreichend sein. Sind den ausreichend Ressourcen für ein derart hohes Limit vorhanden? Ein höheres Limit bedingt nicht eine höhere/bessere Performance.


    Oder laufen bei dem Nutzer tatsächlich mehr als 64 Prozesse? Wenn nicht, wird das Prozesslimit nicht die Ursache gewesen sein.

  • Wenn man in die man page von ulimit schaut:

    Dies sollte somit das Prozesslimit aus dem Angebot des Nutzers sein. Das Limit 64 ist imho schon sehr hoch. 256 wäre extrem hoch. 32 sollte als Standardwert ausreichend sein. Sind den ausreichend Ressourcen für ein derart hohes Limit vorhanden? Ein höheres Limit bedingt nicht eine höhere/bessere Performance.


    Oder laufen bei dem Nutzer tatsächlich mehr als 64 Prozesse? Wenn nicht, wird das Prozesslimit nicht die Ursache gewesen sein.

    Also die RUN-File wird auf jeden Fall neu geschrieben, wenn ich das Angebot ändere. Aber es schein der angebene Wert aus der PD-Admin UI wird im RUN-File verdoppelt. Tatsächlich klappt es bei mir erst ab einem UI Wert von ca. 100 Prozessen, vorher erhalte ich o.g. Meldung.


    PD-Admin läuft in diesem Fall in einem LX-Container. Im Container gibt es mehr als 64 Prozesse, für den PD-Admin User gibt es natürlich deutlich weniger. Z.Zt. ~ 5. Wäre in diesem Fall interessant, wie sich ulimit mit LXC verhält.

  • Ich glaube nicht ... hab es mal durchlaufen lassen und läuft beim ./update.sh auf einen Fehler:


    Code
    Can't load '/opt/pdadmin/lib/auto/Crypt/Passwd/XS/XS.so' for module Crypt::Passwd::XS: /opt/pdadmin/lib/auto/Crypt/Passwd/XS/XS.so: wrong ELF class: ELFCLASS64 at PERL2EXE_STORAGE/XSLoader.pm line 70.
    at /opt/pdadmin/lib/Crypt/Passwd/XS.pm line 6
    Compilation failed in require at PERL2EXE_STORAGE/ConsolidatedAdminAndCustomerCode.pm line 770.
    BEGIN failed--compilation aborted at PERL2EXE_STORAGE/ConsolidatedAdminAndCustomerCode.pm line 770.
    Compilation failed in require at /opt/pdadmin/bin/httpd_vhosts.pl line 30.
    BEGIN failed--compilation aborted at /opt/pdadmin/bin/httpd_vhosts.pl line 30.
    Update erfolgreich.
    root@web01:~/pdadmin#
  • da steht doch "Update erfolgreich" ;-)

    genauso wie bei install-all.sh, wo am Ende erscheint "pd-admin wurde erfolgreich installiert.", auch wenn während der Installation nur Fehler auftreten …

    Das Webinterface war mit selbiger Meldung offline. Da die XS.so nicht geladen werden konnte, hatte ich nicht erwähnt - sorry :)