Problem mit RDNS

  • Hallo,

    ich sitze jetzt zwei Tage an folgendem Problem und bin zu der erkenntnis gekommen, wenn ich nicht Opfer von Corona werde, treibt mich dieses RDNS in den Wahnsinn. Folgendes Problem:


    Ich versuche eine E-Mail an eine Behörde zu schicken. Ich denke die haben ihre Server entsprechend abgesichert und darum kommt es erst zu dem Problem. Bei anderen Empfängern läuft es nämlich ohne Probleme.


    Ich bekomme folgende Mail zurück

    Code
    Hi. This is the qmail-send program at s1.stefanb341.de.
    I'm afraid I wasn't able to deliver your message to the following addresses.
    This is a permanent error; I've given up. Sorry it didn't work out.
    <NUTZER@BEHÖRDE.de>:
    62.225.66.200 does not like recipient.
    Remote host said: 550 Invalid RDNS entry for 85.25.93.254
    Giving up on 62.225.66.200.


    Mein Hostname ist: s1.stefanb341.de

    Die Einstellung bei Betreiber des Servers habe ich entsprechend gemacht 85.25.93.254 -> s1.stefanb341.de


    Hat jemand eine Idee wo das Problem sein könnte?

  • Für 85.25.93.254 ist als Name mail.myinfinity.life festgelegt, aber für mail.myinfinity.life wurde kein A Eintrag vorgenommen. Das müsstest Du noch machen, A Eintrag für mail.myinfinity.life auf 85.25.93.254

  • Für 85.25.93.254 ist als Name mail.myinfinity.life festgelegt, aber für mail.myinfinity.life wurde kein A Eintrag vorgenommen. Das müsstest Du noch machen, A Eintrag für mail.myinfinity.life auf 85.25.93.254

    Ok, jetzt wird kompliziert.. zumindest für mich.... wo muss ich den Eintrag anlegen?

    Also bei mir sieht es so aus, dass ich einen Anbieter habe wo ich den Server gemietet habe. Dort kann ich nur einen Eintrag vornehmen. Da habe ich ja bei dem RDNS 85.25.93.254 -> s1.stefanb341.de eingegeben. Muss ich das ändern?


    oder


    Bei dem Anbieter wo ich meine Domains registriere einen neuen A-Record anlegen?

  • Vielleicht darf ich nochmal zusammenfassen


    1) Das ganze hat auch mit dem Namen zu tun, mit dem sich der Server im SMTP Dialog meldet. Das steht in /var/qmail/control/me

    Nehmen wir hier mal s1.stefanb341.de an. Achtung, wenn Du den Namen da drin änderst, musste Du qmail neu starten (oder halt den ganzen Server rebooten wenn Du Dir damit leichter tust).


    2) In der Folge sollte s1.stefanb341.de auch auf die IP des Servers zeigen (normaler A Record bei Deinem Domain / DNS Anbieter). Das dürfte schon der Fall sein.


    3) für die IP 85.25.93.254 sollte ein PTR (also der rdns) Eintrag auf s1.stefanb341.de existieren. Das ist momentan hier nicht der Fall und wird wohl auch das ausschlaggebende Problem sein. Hier ist der Ansprechpartner der "Besitzer" der IP, also Dein Serverhoster. Wenn Du der Meinung bist, dass Du das in dessen Kundenbereich richtig eingetragen hast, würde ich den Support da mal bemühen.


    Ich persönlich finde es immer am einfachsten die PTR Einträge mit dig zu prüfen sofern Du das installiert hast.


    Code
    dig -x 85.25.93.254

    Oder eben mit Webtools wie mxtoolbox etc.

  • Hallo,

    ich kenne das so, dass man den reverse DNS nur beim Leitungsanbieter eintragen kann, dem ja dieser IP-Kreis gehört.

    Also, wenn ich einen Anschluß von Unitymedia habe, aber mein Server z.B. bei Strato steht, dann kann ich bei Strato zware den forward-DNS Eintrag vornehmen, das wäre der A-Record und der MX-Record für dem Mailserver, vielleicht noch einem CNAME usw.

    Aber die RDNS-Einträge müsste ich in meinem Beispiel bei Unitymedia einstellen, das geht nicht über Strato.

    Ich hoffe, das hilft dir.


    Mit freundlichem Gruß,

    Philipp

  • OK, mein Fehler, ich dachte er hat den Server "on premise" in der Firma stehen!

    Aber das Prinzip ist ja dasselbe: wenn er einen anderen Provider als DNS-Provider nimmt, dann muss er dort die forward-DNS Einträge pflegen und beim Hoster des physischen Servers die reverse Einträge. Also dort, wo die IP-Adressen des Hosting-Netzwerkes "am Server anstehen".

    Mit freundlichem Gruß,

    Philipp

  • 1) Das ganze hat auch mit dem Namen zu tun, mit dem sich der Server im SMTP Dialog meldet. Das steht in /var/qmail/control/me

    Nehmen wir hier mal s1.stefanb341.de an.

    Ja, das steht da drin.



    Das Problem hat sich geklärt. Ich habe ein Ticket beim Anbieter meiner Server angeschrieben. Als Standardantwort kam natürlich erstmal "....kann bis zu 48 Stunden dauern ..... muss sich im Internet verbreiten....".

    Bei dem anderen Server war es aber relativ schnell durch. Das habe ich denen dann so mitgeteilt und danach ging es relativ schnell.



    Danke für eure Hilfe und die Erklärungen.