Please check the 'mime_magic' config option …

  • pd-admin: 4.63

    SE: 0.356


    Beim Update der SE von erhalte ich folgende Meldung:

    Was muss ich da "checken"?

    Code
    grep mime /usr/local/pd-admin2/htdocs/roundcubemail/config/config.inc.php
    // mime magic database
    $config['mime_magic'] = '/usr/share/misc/magic';
    Code
    ls -l /usr/share/misc/magic
    lrwxrwxrwx 1 root root 13 Jan 7 2011 /usr/share/misc/magic -> ../file/magic
    ls -l /usr/share/file/magic
    total 0

    Was muss ich machen, damit dieser Hinweis verschwindet?

  • pd-admin: 4.63

    SE: 0.356

    Welche Reihe wird denn hier aktualisiert?

    Bash
    $ grep mime /usr/local/pd-admin2/htdocs/roundcubemail/config/config.inc.php
    $

    Bei mir steht in der Konfig nichts drin. Mir ist beim Aktualisieren auch nichts aufgefallen... Zudem ist mime_magic deprecated und durch fileinfo ersetzt worden. Fileinfo wiederum ist in PHP enthalten, Bsp:

    Bash
    $ /usr/local/pd-admin2/bin/php5-5.6-cli -i | grep fileinfo
    fileinfo
    fileinfo support => enabled
    $ /usr/local/pd-admin2/bin/php-7.4-cli -i | grep fileinfo
    fileinfo
    fileinfo support => enabled


    Was muss ich da "checken"?


    Was muss ich machen, damit dieser Hinweis verschwindet?

    Kommt es denn abgesehen von der Warnung zu Fehlern?

  • Ich hatte diese Meldung auch bei Notfall-SE-Update wegen dem Qmail-Leck.


    Jedoch auf dem neu installierten Debian9 hatte ich das nicht.

    |

    | ROUNDCUBEMAIL wird upgegradet.

    |

    mysql: [Warning] Using a password on the command line interface can be insecure.

    mysql: [Warning] Using a password on the command line interface can be insecure.

    What version are you upgrading from? Type '?' if you don't know.

    Executing database schema update.

    This instance of Roundcube is up-to-date.

    Have fun!

    mysql: [Warning] Using a password on the command line interface can be insecure.

    Ticket_2019102267002761 returned true

    |

    | phpMyAdmin < 4.8.4 and phpPgAdmin no longer available, use $hostname/adminer

    |




    Jedoch auf dem eigentlich identischen Centos8.1 kam der Hinweis:

    |

    | ROUNDCUBEMAIL wird upgegradet.

    |

    mysql: [Warning] Using a password on the command line interface can be insecure.

    mysql: [Warning] Using a password on the command line interface can be insecure.

    What version are you upgrading from? Type '?' if you don't know.

    WARNING: Mimetype to file extension mapping doesn't work properly!

    Please check the 'mime_types' config option and run this script again.

    Executing database schema update.

    This instance of Roundcube is up-to-date.

    Have fun!

    mysql: [Warning] Using a password on the command line interface can be insecure.

    Ticket_2019102267002761 returned true

    |

    | phpMyAdmin < 4.8.4 and phpPgAdmin no longer available, use $hostname/adminer

    |