Internal Server Error: End of script output before headers: administrator.cgi

  • Hallo,


    ich habe gestern ein Distupgrade des Betriebssystems durchgeführt und dabei auch bei PD-Admin und SEU die neuseste Version installiert

    Seit dem kann ich mich nicht mehr im PD-Admin einloggen. Im Errorlog kommt nur untere Meldung:

    ...

    [cgid:error] [pid 4016] [client xxx.xxx.xxx.xx:52936] End of script output before headers: administrator.cgi, referer: http://web1.meinedomain.com/administrator/

    ...


    OS: Debian 9 (upgrade von Debian 8)

    SEU: 0361

    Pd-Admin: v4.64


    Hatte diese Problem schon mal jemand? Mit der Suche konnte ich leider nichts finden.


    Danke und Grüße

    Urban

  • Die Beta lässt sich leider nicht installieren. Fehler:

    ...

    Aendere Feld whitelist.id

    Can't load '/opt/pdadmin/lib/mysql.so' for module DBD::mysql: libssl.so.10: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden at PERL2EXE_STORAGE/DynaLoader.pm line 200.

    at /opt/pdadmin/bin/httpd_vhosts.pl line 15

    Compilation failed in require at /opt/pdadmin/bin/httpd_vhosts.pl line 15.

    BEGIN failed--compilation aborted at /opt/pdadmin/bin/httpd_vhosts.pl line 15.


    Update erfolgreich.

    ...

  • Hallo.


    Ich habe seit dem Update auf pd-admin 4.66 auch das Problem, dass ich die Adminoberfläche nicht mehr aufrufen kann. Login funktioniert, aber danach kommt der 500er Fehler. Im Errorlog steht nur "End of script output before headers: administrator.cgi"


    Mit pd-admin 4.65 lief alles problemlos!


    System: Debian 9

    SE: 6.365

    pd-admin: 4.66

    Apache: 2.4


    Wie kann ich nachvollziehen, warum es bei der administrator.cgi knallt?

    Wie kann ich testweise wieder auf pd-admin 4.65 zurück, um wenigstens ein paar Einstellungen vorzunehmen?

  • Es muss immer noch der Debian 10 Fix durchgeführt werden ... Danke an Twilo


    Code
    # Fix für Debian 10
    (
    cd /usr/lib/x86_64-linux-gnu
    ln -s libssl.so.1.1 libssl.so.10
    ln -s libcrypto.so.1.1 libcrypto.so.10
    )