nextcloud intl.so

  • Bei einer Nextcloud-Installation tritt immer folgende Meldung auf, im Sekundentakt.


    You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /home/k1xxxdbo/go.domain.de/nextcloud_2020_1_JM/3rdparty/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18


    Hat jemand eine idee was man da tun kann und soll?

  • Also, wenn ich mal im Netz suche, dann scheint die Abhilfe zu sein das Modul "php-intl" zu aktivieren und dann sollte das Problem weg sein.


    Habe jetzt gerade mal geschaut. Füge einfach in die php.ini


    extension="intl.so"


    hinzu. Dann sollte es klappen.

  • genau damit hakt es ja. in der php.ini ist es drin und in der phpinfo steht auch:


    intl

    ICU version 58.3
    ICU Data version 58.3
    ICU TZData version 2019a
    ICU Unicode version 9.0
    intl.default_locale utf8 utf8
    intl.error_level 2 2
    intl.use_exceptions 0 0
  • Dann wären mehr Informationen hilfreich...


    Ich setze Nextcloud 19 ein. Ausgeführt wird es mit FPM und PHP Version 7.4. Installiert ist die SE 6-0.369. Ich habe keinerlei derartige Meldungen.


    Ich würde auch vermuten, dass die 3rd Party App "Patchwork" hier die Meldungen erzeugt und nicht Nextcloud selbst. Müsste man also einmal schauen welche Vorgaben der Hersteller für die App hat.

  • Ich habe die Ursache gefunden...
    Problem war das ich die php.ini nicht in das Kunden-Verzeichnis, /home/k1xxxdbo/php.ini gesetzt habe sondern erst in das Subdomain-Root: /home/k1xxxdbo/go.domain.de/nextcloud_2020_1_JM/php.ini


    Das hat dazu geführt das nextcloud zwar die php.ini gelesen hat, aber die Plugins die in einem anderen Verzeichnis starten wohl nicht.


    Der Grund warum ich das eigentlich so gemacht habe war weil der der kunde unter http://www.domain.de eine wordpress installation hat und die php.ini nicht die gleiche sein sollte wie die für nextcloud unter go.domain.de.

    Aber mit der gleichen php.ini für beides geht jetzt alles korrekt.