Update auf 4.76 mit sql error

  • Hallo zusammen,


    habe grade das Update auf 4.76 gestartet und folgenden Fehler erhalten. Vorher hatte ich auch die SE aktualisiert ohne Fehler. Was ist passiert? Das System lief vorher problemlos? Wo ist die mysql.so hin?


    ##############################################
    # #
    # Willkommen beim Update auf pd-admin 4.76 #
    # #
    ##############################################

    Build:

    Aendere Feld accounts.id
    Aendere Feld accounts.reseller
    Aendere Feld accounts.service_limit
    Aendere Feld applications.vhost
    Aendere Feld applications.name
    Aendere Feld applications.id
    Aendere Feld codomains.domain
    Aendere Feld codomains.name
    Aendere Feld codomains.id
    Aendere Feld config.id
    Aendere Feld crontab.hour
    Aendere Feld crontab.owner
    Aendere Feld crontab.month
    Aendere Feld crontab.min
    Aendere Feld crontab.day_of_week
    Aendere Feld crontab.day_of_month
    Aendere Feld crontab.id
    Aendere Feld domains.name
    Aendere Feld domains.id
    Aendere Feld errordocs.vhost
    Aendere Feld errordocs.type
    Aendere Feld errordocs.id
    Aendere Feld forwarder_targets.forwarder
    Aendere Feld forwarder_targets.address
    Aendere Feld forwarder_targets.id
    Aendere Feld forwards.id
    Aendere Feld ftp.password
    Aendere Feld ftp.id
    Aendere Feld greylist.id
    Aendere Feld ip.id
    Aendere Feld ipv6.address
    Aendere Feld ipv6.id
    Aendere Feld ipv6.reseller
    Aendere Feld mailinglists.id
    Aendere Feld mailthrottle.ts
    Aendere Feld mailthrottle.rcptcount
    Aendere Feld mailthrottle.pop3id
    Aendere Feld mysql_subaccounts.owner
    Aendere Feld mysql_subaccounts.id
    Aendere Feld mysqldb.owner
    Aendere Feld mysqldb.id
    Aendere Feld navigation.type
    Aendere Feld navigation.id
    Aendere Feld navigation_text.navigation_id
    Aendere Feld navigation_text.id
    Aendere Feld new_passwd.ip
    Aendere Feld new_passwd.time
    Aendere Feld new_passwd.session
    Aendere Feld new_passwd.user
    Aendere Feld new_passwd.id
    Aendere Feld pop3.localpart
    Aendere Feld pop3.login
    Aendere Feld pop3.password
    Aendere Feld pop3.vhost
    Aendere Feld pop3.id
    Aendere Feld privilege.user
    Aendere Feld privilege.privilege
    Aendere Feld privilege.id
    Aendere Feld resellers.id
    Aendere Feld resellers.account
    Aendere Feld resellers.passwd
    Aendere Feld servers.id
    Aendere Feld sessions.time
    Aendere Feld sessions.twofa_authenticated
    Aendere Feld sessions.session
    Aendere Feld sessions.user
    Aendere Feld sessions.id
    Aendere Feld smtpauth_logins.mailid
    Aendere Feld smtpauth_logins.timestamp
    Aendere Feld spamassassin_config.preference
    Aendere Feld spamassassin_config.id
    Aendere Feld spamassassin_config.username
    Aendere Feld spamfilter_config.item
    Aendere Feld spamfilter_config.id
    Aendere Feld ssl_orders.sni
    Aendere Feld ssl_orders.id
    Aendere Feld ssl_proxy.vhost
    Aendere Feld ssl_proxy.id
    Aendere Feld traffic.date
    Aendere Feld traffic.id
    Aendere Feld traffic_new.id_user
    Aendere Feld traffic_new.date
    Aendere Feld traffic_new.id
    Aendere Feld twofa.user
    Aendere Feld twofa.id
    Aendere Feld user.id
    Aendere Feld users.id
    Aendere Feld users.www
    Aendere Feld users.mail
    Aendere Feld users.passwd
    Aendere Feld users.mysql
    Aendere Feld vhosts.php5_version
    Aendere Feld vhosts.id
    Aendere Feld vhosts.targetmode
    Aendere Feld vhosts.php_sapi
    Aendere Feld vhosts.redirtohttps
    Aendere Feld whitelist.id
    Can't load '/opt/pdadmin/lib/mysql.so' for module DBD::mysql: libssl.so.10: cannot open shared object file: No such file or directory at PERL2EXE_STORAGE/DynaLoader.pm line 200.
    at /opt/pdadmin/bin/httpd_vhosts.pl line 15
    Compilation failed in require at /opt/pdadmin/bin/httpd_vhosts.pl line 15.
    BEGIN failed--compilation aborted at /opt/pdadmin/bin/httpd_vhosts.pl line 15.

    Update erfolgreich.

  • Es lag einfach daran, dass ich die 64bit Version gestartet habe, aber wohl noch eine 32bit-Version verwende. Mit dem anderen Paket ging es dann sofort.


    Also siehe:


    Code
    64-bit-Version: <http://download.pd-admin.de/pdadmin_v4_64.tar.gz>
    SHA256-Prüfsumme: 97b43ecf66cd8ad34093fa4aee0062152642bcbc9720413556c6c8591c09d9e2
    32-bit-Version (legacy): <http://download.pd-admin.de/pdadmin_v4.tar.gz>
    SHA256-Prüfsumme: b7d91d4542b6d7790b0f47f88eb9d5e6acacb82bc95971e2e0aefa9edd5f94cf
  • Hmmm, also kann man immer noch nicht einfach von der 32Bit Version auf die 64Bit version upgraden ?


    Mein derzeitiges System Debian 8.10



    Das ist schade