Fehler nach Update auf pd-admin v4.80

  • Code
    Can't locate ConsolidatedAdminAndCustomerCode.pm in @INC (@INC contains: /opt/pdadmin/lib /usr/local/pd-admin2/lib/perl5/5.10.1/x86_64-linux /usr/local/pd-admin2/lib/perl5/5.10.1 /usr/local/pd-admin2/lib/perl5/site_perl/5.10.1/x86_64-linux /usr/local/pd-admin2/lib/perl5/site_perl/5.10.1 /usr/local/pd-admin2/lib/perl5/site_perl .) at /opt/pdadmin/bin/httpd_log.pl line 13.
    BEGIN failed--compilation aborted at /opt/pdadmin/bin/httpd_log.pl line 13.
  • Ich habe das auf 3 Debian Systemen, bei allen ist pd-admin v4.80 installiert


    Debian 10 (buster) mit 64 bit pd-admin

    Debian 8.11 (jessie) mit 64 bit pd-admin

    Debian 7.11 (wheezy) mit 32 bit pd-admin


    Wo liegt bei euch die Datei ConsolidatedAdminAndCustomerCode.pm?


    locate ConsolidatedAdminAndCustomerCode.pm

    bzw.

    find / -type f -name ConsolidatedAdminAndCustomerCode.pm

    findet nichts

  • Ich hab eben das Update pd-admin v4.81 das diesen Fehler fixen soll installiert (32bit Version). Leider kommt der Fehler immer noch.


    Code
    Can't locate ConsolidatedAdminAndCustomerCode.pm in @INC (@INC contains: /opt/pdadmin/lib /usr/local/pd-admin2/lib/perl5/5.10.1/x86_64-linux /usr/local/pd-admin2/lib/perl5/5.10.1 /usr/local/pd-admin2/lib/perl5/site_perl/5.10.1/x86_64-linux /usr/local/pd-admin2/lib/perl5/site_perl/5.10.1 /usr/local/pd-admin2/lib/perl5/site_perl .) at /opt/pdadmin/bin/httpd_log.pl line 13.
    BEGIN failed--compilation aborted at /opt/pdadmin/bin/httpd_log.pl line 13.
  • Ich hab eben das Update pd-admin v4.81 das diesen Fehler fixen soll installiert (32bit Version). Leider kommt der Fehler immer noch.


    Code
    Can't locate ConsolidatedAdminAndCustomerCode.pm in @INC (@INC contains: /opt/pdadmin/lib /usr/local/pd-admin2/lib/perl5/5.10.1/x86_64-linux /usr/local/pd-admin2/lib/perl5/5.10.1 /usr/local/pd-admin2/lib/perl5/site_perl/5.10.1/x86_64-linux /usr/local/pd-admin2/lib/perl5/site_perl/5.10.1 /usr/local/pd-admin2/lib/perl5/site_perl .) at /opt/pdadmin/bin/httpd_log.pl line 13.
    BEGIN failed--compilation aborted at /opt/pdadmin/bin/httpd_log.pl line 13.

    was gibt file /opt/pdadmin/bin/httpd_log.pl aus?


    Da sollte folgendes erscheinen:

    Code
    /opt/pdadmin/bin/httpd_log.pl: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.0.0, stripped
  • Danke Twilo, aber ich hab jetzt in der Zwischenzeit leider auch kein System mehr mit 32bit pd-admin, da ich bei den paar Servern wo ich das Problem hatte die 64bit drüber genagelt habe (wo das Problem nicht besteht).


    Ich werd das jetzt zum Anlass nehmen und die nächsten Tage überall die 64bit installieren. Bisher war ich da etwas schüchtern und habe weiterhin die 32bit verwendet, aber es scheint soweit alles gut zu laufen damit.