Beiträge von AzgP

    Das regelmässige Updates kommen ist auch ein wirklich toller service. Und das dabei auchmal Fehler passieren können ist ganz verständlich.


    Es wäre halt nur schöner, wenn man sobald ein Fehler bekannt ist auch eine Info bekommt (z.B. in der schönen Rundmail) damit man den Fehler beheben kann. Ansonsten installiert man nur kurz das update bevor man wieder weg ist und schaut erst nach ein paar Stunden nach dem Rechten und man hat den Schlamassel. Ich schau immer nur kurz nach, ob apache und mysql wieder angelaufen sind und prüf nicht alles direkt durch wenn ich es eilig habe.

    ok dieser Befehl reicht aus. Es wäre sehr nett gewesen, wenn eine Rundmail gekommen wäre damit man dies ausführen kann. Die EMails die in der Zwischenzeit gekommen sind, wurden bis jetzt allerdings nciht zugestellt. Scheinbar sind somit Bestellungen von Kunden im pd-admin Nirvana verloren :O

    ok das problem hat sich erledigt.
    allerdings lässt sich der mysql server nicht stoppen. musste fürs update den harten weg nehmen und in der inittab folgendes auskommentieren SV:123456:respawn:/command/svscanboot
    dann das updateinstallieren (vorher alle prozesse killen) und dann das system neu starten weil auch der startbefehl fürs mysql nicht funktionierte. Da ich dieses Prob auf einem anderen unserer Server, der identisch installiert wurde nicht hatte frage ich mich, ob ich pd-admin über die alte version installieren kann, so, dass aber alle konfigurationen und kunden und datenbanken vorhanden bleiben. Ist des möglich?

    nächstes update fast gleiches lustiges spielchen


    done
    |
    | trying to stop apache ...
    |
    done
    |
    | trying to stop apache ...
    |
    done
    |
    | trying to stop apache ...
    |
    und immer so fort. da wo vorher svc command not found stand steht jetzt done. aber immer noch die schleife die ne zeit brauchst (so 2-3 minuten) und dann auf einmal funktioniert

    meinst du die pdadmin oder se? (Das update)
    wenn du pdadmin updatest lösch vorher die vorhandene pdadmin.tar...
    datei. wenn du einfach mit wget die neue lädst und die "überschreiben" lässt ist immernoch die alte version auf deinem server.

    hmm. das wars.
    habe auf dem 2. server kurz PATH=$PATH:/usr/local/bin ausgeführt und update funktionier tadellos.
    das einzige ist. wo kann ich dies direkt eintragen, damit er das immer automatisch nimmt. wir machen pd-admin als root updaten, melden uns aber mit einem user an und dann per su zum admin.
    daher funktioniert die variante mit profile.local nicht, da die nur für den angemeldeten user ist und nicht für den root.

    Eintrag Bug-Forum: Dies ist eine vorgefertigte Schablone, die bei der Formulierung eines Bugreports unterstützen soll. Bitte die folgenden Angaben möglichst vollständig ausfüllen.


    - Welche Version von pd-admin wird eingesetzt? aktuelle
    - Welche Version der Standard-Serverumgebung wird eingesetzt? aktuelle
    - Wie sind die problematischen Dienste konfiguriert? SE-Standard
    - Welche Logfile-Einträge (zB. Webserver- oder Mail-Logfile) gibt es?


    Wenn man nach der Anleitung den Hostnamen als Wildcard definiert, funktionieren EMails an viele verschiedene EMail-Anbieter nicht mehr, da das Sternchen als Sonderzeichen erkannt wird und diese dann nicht zugestellt werden (Error 501. Verschiedene Meldungen. Bedeutung, der EMailserver kann den Hostnamen nicht erkennen). Dieses Problem liegt zwar nicht an pd-admin, aber es ist sicher interessant zu wissen, warum z.B. bei web.de und co die emails nicht ankommen (werden dort ca. 2 wochen gespeichert und dann aus der queue gelöscht)

    Der gesamte Pfad ist ja leicht anders. Wobei bei mir die ganzen Sachen die du in local hast bei mir wohl eins tiefer liegen. warum auch immer


    btw wie muss ich das ändern.

    habe gerade mal unter packages nachgesehen. also es ist alles vorhanden. untr command der symlink ist auch da


    2007-03-28 17:46 svc -> /packages/admin/daemontools/command/svc

    das sollte sich doch eigentlich automatisch selber mitinstalliert haben oder nicht? der Server wurde gerade erst vor gut 1 Monat installiert.

    so heute habe ich von 1.083 auf die aktuelle 084 geupdated.


    Es kam wieder gut 300-400 mal die Meldung (alle anderen Dienste konnten problemlos gestoppt werden)
    Nach den 300-400 Meldungen scheint es anscheinend zu klappen und der apache ist aus (oder das updatescript ignoriert die meldung) und das update geht ansonsten fehlerfrei durch.

    Dies ist eine vorgefertigte Schablone, die bei der Formulierung von Problemen unterstützen soll. Bitte die folgenden Angaben möglichst vollständig ausfüllen.


    - Welche Version von pd-admin wird eingesetzt? 3.38
    - Welche Version der Standard-Serverumgebung wird eingesetzt? 1-0.081
    - Wie sind die problematischen Dienste konfiguriert? standard


    Habe mit unserem neuen Server doch einige Probleme. Wenn ich ein Update installieren möchte kommt immer folgende Fehlermeldung:


    |
    | trying to stop apache ...
    |
    ./se-update.sh: line 408: svc: command not found
    done


    Wenn ich dann den Daemon installieren möchte per Hotfix bzw. Apache per Hand stoppen will kommt:
    h1215896:~ # sh hotfix-0009.sh
    *************************************************************************
    hotfix 0009: please wait ...
    *************************************************************************
    directory /service/apache
    found, hotfix not applicable
    h1215896:~ # svc -d /service/apache
    bash: svc: command not found
    h1215896:~ # /usr/local/pd-admin2/bin.apachectl stop
    bash: /usr/local/pd-admin2/bin.apachectl: Datei oder Verzeichnis nicht gefunden
    h1215896:~ # cd seu3

    ach geht doch alles einigermassen flott


    und phpbb kommt ja nur in das kundenverzeichnis des kunden. aber die installroutine ist einfach und gut