Beiträge von DirkE

    Vielen Dank Sumeragi. Es gab tatsächlich einen Unterschied im zugewiesenen Arbeitsspeicher den ich übersehen hatte. Der manuelle Start brachte dann eine deutlichere Fehlermeldung:


    Code
    /service/FPM-solotcbc-7.4.2/run
    starting PHP-FPM server for solotcbc
    /usr/local/pd-admin2/php-7.4.2/sbin/php-fpm: error while loading shared libraries: libbrotlicommon.so.1: failed to map segment from shared object: Cannot allocate memory
    PHP-FPM server for solotcbc terminated with rc = <127>
    rm: cannot remove '/service/FPM-solotcbc-7.4.2/socket': No such file or directory
    starting fallback server for solotcbc
    /usr/local/pd-admin2/php-7.4.2/sbin/php-fpm: error while loading shared libraries: libbrotlicommon.so.1: failed to map segment from shared object: Cannot allocate memory


    Jetzt läuft alles so wie es soll.


    Auch an Eisenherz nochmal danke für die schnelle Unterstützung.


    Dirk

    Alle Kombinationen bringen den 500er... Eine php-info-Datei wird auch nicht ausgeführt.


    Bei cgiwrap:

    Code
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator at dirk@##### to inform them of the time this error occurred, and the actions you performed just before this error.
    More information about this error may be available in the server error log.

    Bei fpm:

    Code
    Service Unavailable
    The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.


    im error_log mit cgiwrap:

    Code
    [Sat Aug 01 17:16:42.437576 2020] [cgid:error] [pid 21737] [client 217.61.194.123:60223] End of script output before headers: php5-cgiwrap


    fpm:

    Code
    [Sat Aug 01 17:14:38.270719 2020] [proxy:error] [pid 15774] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /service/FPM-solotcbc-7.4.2/socket (*) failed
    [Sat Aug 01 17:14:38.270933 2020] [proxy_fcgi:error] [pid 15774] [client 217.61.194.123:60214] AH01079: failed to make connection to backend: httpd-UDS

    Dirk

    Hallo,


    ich habe ein Problem mit einer pd-admin Installation (CentOS 7.5, Serverumgebung 0.348, pd-admin 4.65, Problem trat aber schon unter 4,62 auf). Ich nutze den Server seit längerer Zeit mit dem Endkunden, den ich direkt nach der Installation angelegt habe. Hier funktioniert auf mehreren Sites unter mehreren Domains php absolut problemlos.


    Ich habe jetzt einen neuen Endkunden eingerichtet. Bei ihm bekomme ich php nicht zum laufen. Das Skript meldet einen 500er, im error_log erscheint Folgendes:


    Code
    [Sat Aug 01 12:10:33.928476 2020] [proxy:error] [pid 761] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /service/FPM-solotcbc-7.4.2/socket (*) failed
    [Sat Aug 01 12:10:33.928783 2020] [proxy_fcgi:error] [pid 761] [client 217.61.194.123:58129] AH01079: failed to make connection to backend: httpd-UDS


    Der Socket fehlt dann auch im angegebenen Pfad /service/FPM-solotcbc-7-4.2/ . Für den funktionierenden Endkunden ist der Socket an der entsprechenden Stelle vorhanden.


    Ändern der php-Version oder Wechsel zwischen cgiwrap und fpm ändert nichts an dem Problem.


    Hat von euch jemand eine Idee? Irgendwie fehlt mir da ein Ansatz um der Lösung näher zu kommen.


    Grüße


    Dirk