Beiträge von tooliload

    da steht doch "Update erfolgreich" ;-)

    genauso wie bei install-all.sh, wo am Ende erscheint "pd-admin wurde erfolgreich installiert.", auch wenn während der Installation nur Fehler auftreten …

    Das Webinterface war mit selbiger Meldung offline. Da die XS.so nicht geladen werden konnte, hatte ich nicht erwähnt - sorry :)

    Ich glaube nicht ... hab es mal durchlaufen lassen und läuft beim ./update.sh auf einen Fehler:


    Code
    Can't load '/opt/pdadmin/lib/auto/Crypt/Passwd/XS/XS.so' for module Crypt::Passwd::XS: /opt/pdadmin/lib/auto/Crypt/Passwd/XS/XS.so: wrong ELF class: ELFCLASS64 at PERL2EXE_STORAGE/XSLoader.pm line 70.
    at /opt/pdadmin/lib/Crypt/Passwd/XS.pm line 6
    Compilation failed in require at PERL2EXE_STORAGE/ConsolidatedAdminAndCustomerCode.pm line 770.
    BEGIN failed--compilation aborted at PERL2EXE_STORAGE/ConsolidatedAdminAndCustomerCode.pm line 770.
    Compilation failed in require at /opt/pdadmin/bin/httpd_vhosts.pl line 30.
    BEGIN failed--compilation aborted at /opt/pdadmin/bin/httpd_vhosts.pl line 30.
    Update erfolgreich.
    root@web01:~/pdadmin#

    Eine DKIM-Unterstuetzung fuer die Serverumgebung ab Reihe 4 ist aktuell bei uns in Arbeit. Bis die Funktion inkl. Integration in pd-admin zur Verfuegung steht, werden aber noch einige Wochen vergehen.

    Da habe ich schon was fertig gemacht und nutze es seit einem Jahr und nun kommt Herr Bradler und verkündet was tolles. :) Muss mal schauen, dass ich meins dann wieder sauber aus dem System bekomme... mit Let´s Encrypt war es damals genau so :)

    Hallo,


    habt ihr interesse an einem DKIM / DomainKey Addon, welches über den Kundenbereich gesteuert werden kann?

    Bitte um Rückmeldung, gerne auch mit der Info welches Template ihr bei PD-Admin verwendet, also Standard oder Responsive.


    Danke.

    Wenn man in die man page von ulimit schaut:

    Dies sollte somit das Prozesslimit aus dem Angebot des Nutzers sein. Das Limit 64 ist imho schon sehr hoch. 256 wäre extrem hoch. 32 sollte als Standardwert ausreichend sein. Sind den ausreichend Ressourcen für ein derart hohes Limit vorhanden? Ein höheres Limit bedingt nicht eine höhere/bessere Performance.


    Oder laufen bei dem Nutzer tatsächlich mehr als 64 Prozesse? Wenn nicht, wird das Prozesslimit nicht die Ursache gewesen sein.

    Also die RUN-File wird auf jeden Fall neu geschrieben, wenn ich das Angebot ändere. Aber es schein der angebene Wert aus der PD-Admin UI wird im RUN-File verdoppelt. Tatsächlich klappt es bei mir erst ab einem UI Wert von ca. 100 Prozessen, vorher erhalte ich o.g. Meldung.


    PD-Admin läuft in diesem Fall in einem LX-Container. Im Container gibt es mehr als 64 Prozesse, für den PD-Admin User gibt es natürlich deutlich weniger. Z.Zt. ~ 5. Wäre in diesem Fall interessant, wie sich ulimit mit LXC verhält.

    Hallo,


    ich habe den zweiten Fehler beheben können, in dem ich in der run-File des Dienstes

    Code
    /service/FPM-schwedbx-5.2.99/run


    Den Wert "ulimit -u 256" gesetzt habe (Ursprünglich 64).

    Wie bekomme ich es hin, dass für alle neuen FPM Services die run-File automatisch wie oben gesetzt ist?


    Viele Grüße


    Tino

    Lege ich zu einem vorhanden Kunden eine Domain an, dann werde ich auf eine nicht vorhandene Seite weitergeleitet.

    (Endkunden-Übersicht -> jeweiliger Endkunde -> Domains -> Neue Domain -> Status Domaineinrichtung -> Fehler "Keine Vorlagen gespeichert" )


    Ändere ich im Endkundenmenü die PHP-Einstellung einer Subdomain (CLI-Änderung sind nicht erlaubt und auf FPM eingestellt), dann ist die Subdomain nicht mehr erreichbar, Fehlermeldung im WWW (The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.)


    Logs:

    Code
    [Tue Mar 10 06:57:50.735723 2020] [proxy:error] [pid 18259] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /service/FPM-schwedbx-5.2.99/socket (*) failed
    [Tue Mar 10 06:57:50.735788 2020] [proxy_fcgi:error] [pid 18259] [client xx:46140] AH01079: failed to make connection to backend: httpd-UDS

    Also die 708 MB Archivgröße ist korrekt ... die 13 MB beziehen sich auf deine Internet-Geschwindigkeit

    Ab und zu dauert es mal beim MySQL Symlink -> je nach dem wie viele Tabellen sich dort angesammelt haben. Kannst ja mal mit "du -h /home/mysql" schauen, was sich angesammelt hat

    Wir haben ebenfalls ein Problem, mit dem Apache. - Apache startet nicht.


    Standardmäßig ist php über cgiwrap ausgeführt. Bei diesem Kunden jedoch ist die Änderung der PHP Ausführung im Angebot erlaubt und PHP-FPM eingestellt.


    Code
    # /opt/pdadmin/bin/httpd_vhosts.pl
    Writing /usr/local/pd-admin2/conf/httpd.conf
    Writing /usr/local/pd-admin2/httpd-2.4/conf/httpd.conf
    webserver = <AP22>
    Apache 22 is already selected
    Syntax error on line 419 of /usr/local/pd-admin2/conf/httpd.conf:
    Invalid command 'FastCgiExternalServer', perhaps misspelled or defined by a module not included in the server configuration



    // Update:

    Das Problem tritt anscheint nur auf wenn Apache 2.2 als Webserver gewählt ist. Mit Apache 2.4 klappt es auf anhieb.

    - Welche Version von pd-admin wird eingesetzt? 4.25
    - Welche Version der Serverumgebung wird eingesetzt? 3-0-265


    SSL bestellen (Beta)


    Beim SSL bestellen kommt es zum Fehler. Die Funktion wird ja als Beta ausgewiesen. Es erfolgt beim "bestellen" folgender Fehler:


    Kann Datei /opt/pdadmin/etc/ssl-validation/EE12C8F9145BD541A9E9F1059DE9B5C5.txt nicht oeffnen.: No such file or directory


    Wie ist diese Funktion eigentlich gedacht? Wird ein selbstsigniertes SSL-Cert erstellt oder bekommt man eine Mail? -> Falls es wie beim Domain registrieren eine einstellbare Vorlage für den Mailrobot geben soll, habe ich sie noch nicht gefunden.


    Endkunden -> Übersicht -> Verwalten


    Die Schaltflächen im Verwalten-Menü werden anders dargestellt, hat ein bisschen was von Bootstrap in weiß. -> Ist das so gewollt oder ein CSS Fehler?


    PHP-FPM (Beta)


    Kann wie genutzt wrden? -> Unter Einstellungen -> Serverkonfiguration ist nichts zu sehen...


    Danke


    Die anderen Funktionen habe ich auch mal kurz getestet, da ist mir nichts weiter aufgefallen. - Wie immer super Arbeit von B&K. Sind nette Funktionen mit dabei. Danke.

    Hallo,


    wir haben heute mal ein System mit Debian 8.2 64Bit aufgesetzt und können ebenfalls den Fehler nachvollziehen.


    In den PHP Error-Logs zeigt sich häufig ein "libgcc_s.so.1 must be installed for pthread_cancel to work"


    Die Lib ist allerdings da.


    Auffällig ist das wenn ein Script mit der PHP Funktion mail() genutzt wird, kommt es z.B. zum oben genannten Fehler.


    Wird die PHP Datei als root ausgeführt = läuft die mail() Funktion und es gibt keinen Fehler in der error_log. Sobald aber PHP als User ausgeführt wird, in unserem Fall über cgiwrap, erscheint die Fehlermeldung wieder in den Logs.


    Ein Eintrag der Datei /lib/x86_64-linux-gnu/libgcc_s.so.1 in /etc/ld.so.preload schafft ebenfalls keine Abhilfe.


    Strace als root: