Beiträge von tooliload

    Also die 708 MB Archivgröße ist korrekt ... die 13 MB beziehen sich auf deine Internet-Geschwindigkeit

    Ab und zu dauert es mal beim MySQL Symlink -> je nach dem wie viele Tabellen sich dort angesammelt haben. Kannst ja mal mit "du -h /home/mysql" schauen, was sich angesammelt hat

    Wir haben ebenfalls ein Problem, mit dem Apache. - Apache startet nicht.


    Standardmäßig ist php über cgiwrap ausgeführt. Bei diesem Kunden jedoch ist die Änderung der PHP Ausführung im Angebot erlaubt und PHP-FPM eingestellt.


    Code
    1. # /opt/pdadmin/bin/httpd_vhosts.pl
    2. Writing /usr/local/pd-admin2/conf/httpd.conf
    3. Writing /usr/local/pd-admin2/httpd-2.4/conf/httpd.conf
    4. webserver = <AP22>
    5. Apache 22 is already selected
    6. Syntax error on line 419 of /usr/local/pd-admin2/conf/httpd.conf:
    7. Invalid command 'FastCgiExternalServer', perhaps misspelled or defined by a module not included in the server configuration



    // Update:

    Das Problem tritt anscheint nur auf wenn Apache 2.2 als Webserver gewählt ist. Mit Apache 2.4 klappt es auf anhieb.

    - Welche Version von pd-admin wird eingesetzt? 4.25
    - Welche Version der Serverumgebung wird eingesetzt? 3-0-265


    SSL bestellen (Beta)


    Beim SSL bestellen kommt es zum Fehler. Die Funktion wird ja als Beta ausgewiesen. Es erfolgt beim "bestellen" folgender Fehler:


    Kann Datei /opt/pdadmin/etc/ssl-validation/EE12C8F9145BD541A9E9F1059DE9B5C5.txt nicht oeffnen.: No such file or directory


    Wie ist diese Funktion eigentlich gedacht? Wird ein selbstsigniertes SSL-Cert erstellt oder bekommt man eine Mail? -> Falls es wie beim Domain registrieren eine einstellbare Vorlage für den Mailrobot geben soll, habe ich sie noch nicht gefunden.


    Endkunden -> Übersicht -> Verwalten


    Die Schaltflächen im Verwalten-Menü werden anders dargestellt, hat ein bisschen was von Bootstrap in weiß. -> Ist das so gewollt oder ein CSS Fehler?


    PHP-FPM (Beta)


    Kann wie genutzt wrden? -> Unter Einstellungen -> Serverkonfiguration ist nichts zu sehen...


    Danke


    Die anderen Funktionen habe ich auch mal kurz getestet, da ist mir nichts weiter aufgefallen. - Wie immer super Arbeit von B&K. Sind nette Funktionen mit dabei. Danke.

    Hallo,


    wir haben heute mal ein System mit Debian 8.2 64Bit aufgesetzt und können ebenfalls den Fehler nachvollziehen.


    In den PHP Error-Logs zeigt sich häufig ein "libgcc_s.so.1 must be installed for pthread_cancel to work"


    Die Lib ist allerdings da.


    Auffällig ist das wenn ein Script mit der PHP Funktion mail() genutzt wird, kommt es z.B. zum oben genannten Fehler.


    Wird die PHP Datei als root ausgeführt = läuft die mail() Funktion und es gibt keinen Fehler in der error_log. Sobald aber PHP als User ausgeführt wird, in unserem Fall über cgiwrap, erscheint die Fehlermeldung wieder in den Logs.


    Ein Eintrag der Datei /lib/x86_64-linux-gnu/libgcc_s.so.1 in /etc/ld.so.preload schafft ebenfalls keine Abhilfe.


    Strace als root:


    Hat schon jemand was davon gehört? Die pd-admin Beta-Version scheint ja nicht mehr online zu sein ...


    Das klingt richtig gut. Danke Herr Bradler.

    Hallo,


    könnt ihr mal probieren, ob euer Roundcube nach Extern noch E-Mails verschickt? Ich habe auf unserem Testsystem den Fehler das dies nach dem Update auf die SE 0.260 und pd-admin 4.24 nicht mehr klappt. (Zugegeben war die Testumgebung die letzten 5 Versionen nicht mehr aktiv und hat daher die ein oder andere SE übersprungen...)


    Roundcube meint:

    Code
    1. [21-Oct-2015 13:56:41 +0200]: <43659793> SMTP Error: Failed to add recipient
    2. 'USER@aol.com'.[B] sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)
    3. (Code: 553) [/B]in /usr/local/pd-admin2/htdocs/roundcubemail/program/lib/Roundcube/rcube.php
    4. on line 1708 (POST /roundcubemail/?_task=mail&_unlock=loading1445428985028&_lang=de_DE&_framed=1?_task=mail&_action=send)


    Die mail.log zeigt:

    Code
    1. Oct 21 13:56:41 SERVER qmail-smtpd: qmail-smtpd/VC started
    2. Oct 21 13:56:41 SERVER qmail-smtpd: domain aol.com not in domains or codomains table
    3. Oct 21 13:58:48 SERVER dovecot: pop3-login: Aborted login (no auth attempts): rip=SERVERIP, lip=SERVERIP


    Trage ich in der /usr/local/pd-admin2/htdocs/roundcubemail/config/main.inc.php für den SMTP Zugangsdaten ein, klappt der Versand wieder auf anhieb ohne Probleme. Probleme mit dem Hostname schließe ich aus, die Konfiguration sieht korrekt aus, ferner hat sich nichts geändert.

    Zitat


    Richtig ist, dass die gewünschte Umstellung auf Dovecot bereits umgesetzt wurde. Damit wurden verschiedene Probleme bei der Mail-Quota beseitigt und auch Quota-Warnungen umgesetzt.


    Das ist wirklich super und es funktioniert ohne Probleme.


    Zitat


    Weitere neue Funktionen sollen in den kommenden Monaten folgen:

    • Flexiblere Mail-Quota
    • Eigener Spam-Ordner für jede Mailbox


    Diese Punkte haben wir bereits für pd-admin umgesetzt.


    Zitat
    • Bestellung von SSL-Zertifikaten über pd-admin


    Ein Punkt der nicht wirklich spannend für mich klingt. Hier wäre es toll, wenn man einen Webservices ansprechen könnte um auch eine entsprechende Rückmeldung der "Bestell-API" auswerten zu können. - Ein Punkt der für Domainbestellungen über PD-Admin ebenfalls wünschenswert wäre.


    Zitat
    • Kunden-eigene ErrorLogs


    Hierzu gibt es (meine ich) ein Howto im Forum?


    Zitat


    Der APS-Package Installer, die automatische Kunden-Migration und neues ein Design - Punkte die ebenfalls hoch auf der Wunschliste standen - sind leider nicht so einfach umzusetzen.


    Die Idee mit dem Design wäre wirklich toll, eventuell auch etwas "freier" mit den Templates umgehen, aktuell wird ja neben den editierbaren Teil auch ein statischer Teil z.B. die Tabellen im pd-admin erzeugt.


    Die Paketinstaller haben wir ebenfalls als Addon im Einsatz, allerdings ist dieser komplett mit eigenen Paketen ausgestattet ohne das ein großer "APS Package Provider" dahinter steckt. Der nächste Schritt soll dahin gehen, dass auch unsere Reseller eigene Pakete ihren Kunden bereitstellen können.

    Wenn du die se-update.sh mit einem Editor öffnest, siehst du die Parameter. Ich habe gerade die se-update.sh nicht da, meine aber das es einen Parameter zum forcen gibt. Probiere mal ./se-update.sh -f

    Ich glaube der Index des Postfaches baut sich neu auf. Die E-Mails könnten einmal im Programm neu geladen werden. Bei mir war es nicht der Fall. Ich kämpfe gerade damit das der Empfang wieder funktioniert :(

    Hallo Herr Bradler,


    die Umstellung hat fast zu 100% funktioniert.
    Hier war es erforderlich in der Datei /usr/local/pd-admin2/dovecot-2.2/etc/dovecot/dovecot.conf noch zusätzlich folgende Angabe zu machen:


    Code
    1. postmaster_address=postmaster at DOMAIN


    Andernfalls wurden die Mails zwar angenommen, waren aber nicht abrufbar.


    Für die Forumsuche: Die Fehlermeldung war: Error:_Error_reading_configuration:_Invalid_settings:_postmaster_address_setting_not_given


    Viele Grüße