Beiträge von neodg

    Seit heute habe ich folgende Fehlermeldungen:


    Gestern Update auf Serverumgebung (SE) 0.293 gemacht und am Abend Debian Updates und neu gestartet. Das zurücksetzen auf 0.292 hat nichts geändert.



    Debian 7, 32bit
    Installierte Version d. Serverumgebung: 3-0.293
    Installierte pd-admin-Version: v4.55


    Gestern habe ich Debian Updates gemacht und neu gestartet, war ein neuer Kernel dabei. Aber ob das der Grund war... HDD und RAM sind nicht voll und auch die Last ist relativ niedrig...

    Ein Tipp für Euch geplagte Leute:


    Ja, mir fehlt auch die Entwicklung von pd-admin. Mir wärs egal wenns was kosten würde, mir wärs egal wenn sich im Lizenzmodell etwas ändert, wenn nur ENDLICH was weitergehen würde.


    Schaut Euch mal das an:


    https://efa-project.org/ GNU - kostenlos


    Hierbei handelt es sich um einen reinen Spam- und Firenfilter (+ Smarthost) den man vor den eigentlichen Mailserver stellt. Man schafft es hier zwar nicht das die Mails in einen eigenen Spamordner kommt (obwohl ich ein Script habe das, weil ja der Betreff auf SPAM geändert werden kann, die Mails in einen Unterordner verschiebt). Aber richtig eingestellt hält es wirklich beinahe alles fern.


    Ist nicht die perfekte Lösung, schafft aber Abhilfe bis Bradler & Krantz in die Puschen kommt (oder stirbt).

    Kurze Antwort auf meine eigene Frage:


    Wer ein letsencrypt Zertifikat für den pd-admin Host selbst verwenden möchte macht nach der Installation von letsencrypt ein:


    Code
    1. /opt/pdadmin/bin/letsencrypt pd-admin-hostname


    danach das Script herunterladen


    für Dovecot: http://download.pd-admin.de/dc-ssl-install.sh und ausführen, danach ist das pd-admin Webinterface, FTP und Mail auch verschlüsselt erreichbar.


    Meiner bescheidenen Meinung nach sollte das ASAP Standard werden!

    So, ich habe einen neuen Server aufgesetzt (CentOS), pd-admin 6 installiert, letsencrypt installiert und SSL Zertifikate erstellen lassen.


    Diese sind auch im Webinterface sichtbar und in /opt/pdadmin/sslcerts nach /etc/letsencrypt/live/ verlinkt. Das passt alles, aber beim Aufruf einer Domain mit https:/ kommt:


    Fehler: Gesicherte Verbindung fehlgeschlagen
    SSL_ERROR_RX_RECORD_TOO_LONG


    In der error.log steht gar nichts und in der access.log steht:


    - 111.111.111.111 - - [04/Mar/2017:09:19:28 +0100] "\x16\x03\x01" 400 226 "-" "-"


    => Verbesserungsvorschläge:
    => SSL Zertifikat für den Host selbst erstellen lassen inkl. phpmyadmin, pd-admin, Webmail, TLS, FTPs etc inkl. Weiterleitung auf https
    => SSL Zertifikate sollte auch ohne www erstellt werden oder gleich Weiterleitungen auf Domain mit www

    Diese Fehlermeldungen kommen:


    /opt/pdadmin/bin/certbot-auto


    Creating virtual environment...
    Installing Python packages...
    Installation succeeded.
    Saving debug log to /var/log/letsencrypt/letsencrypt.log
    Failed to find apache2ctl in PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
    Certbot doesn't know how to automatically configure the web server on this system. However, it can still get a certificate for you. Please run "certbot-auto certonly" to do so. You'll need to manually configure your web server to use the resulting certificate.


    /opt/pdadmin/bin/certbot-auto --all
    Saving debug log to /var/log/letsencrypt/letsencrypt.log
    Failed to find apache2ctl in PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
    Certbot doesn't know how to automatically configure the web server on this system. However, it can still get a certificate for you. Please run "certbot-auto certonly" to do so. You'll need to manually configure your web server to use the resulting certificate.

    Beim installieren des Certbot habe ich gerade diese Meldung bekommen:


    Failed to find apache2ctl in PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
    Certbot doesn't know how to automatically configure the web server on this system. However, it can still get a certificate for you. Please run "certbot-auto certonly" to do so. You'll need to manually configure your web server to use the resulting certificate.


    Da SSL jetzt verpflichtend wird (ansonsten rote Browserleiste), muss das in die SE eingebaut werden!


    Beim ausführen von letsencrypt domainname kommt bei mir:

    Herr Bradler,


    wenn es denn bei so vielen Kunden läuft, wie wäre es dann mit einem HowTo wie man es richtig einstellt und konfiguriert?

    Zitat

    Original von Daniel Bradler
    HSTS koennen Sie ganz einfach aktivieren, indem Sie eine .htaccess-Datei mit dem Inhalt


    Header add Strict-Transport-Security "max-age=15768000"


    anlegen.


    Danke für die Info! Kleiner Wehrmutstropfen, die neue ownCloud Version ersetzt die .htaccess bei jedem Update. Somit muss (auch das) jetzt immer per Hand gepflegt werden. Also bleibt mein Wunsch bestehen.


    Edit: ownCloud macht auch nach dem Eintrag die Fehlermeldung das HSTS nicht läuft. Ich muss mich aber erst intensiver damit beschäftigen.

    Hallo!


    Ich habe ein Wildcardzertifikat. Beim Eintragen in pd-admin meint es aber immer:


    Code
    1. Hostname und Common Name des Zertifikats nicht identisch.


    ich weiß heute ists heiß, oder kapiere ich da was nicht? Wenn ich ein Zertifikat habe, dass auf *.domain läuft und ich es für hugo.domain einrichten möchte, sollte das doch kein Problem sein, oder?

    [list=1]
    [*]Export und Import von einzelnen Kunden, aber auch einfacherer Umzug von einem Server zum Anderen
    [*]Mailspeicher pro Postfach einstellbar
    [*]Updates, aller von pd-admin genutzten Programme (zB. Roundcube)
    [*]Mailserver auf extra Server
    [*] Fehlerlogs die der Kunde selbst ansehen kann, vielleicht sogar eine Möglichkeit diese im Webinterface via tail -f laufend mitzulesen
    [*] sendmail limitieren/abschaltbar machen für jeden Kunden
    [*] Zentrale Verwaltbarkeit für mehrere Server
    [*] Einstellbarkeit der PHP Version auf die letzte Version der Reihe (so wie schon bei php 5.2 möglich)
    [/list=1]

    Hallo!


    Ich wollte gerade bei einem Server von v3 auf v4 updaten. Das Updatescript meint aber:


    checking subdirectory structure before importing changed files
    /usr/local/pd-admin2/bin/perl: 1: /usr/local/pd-admin2/bin/perl:ELF: not found
    /usr/local/pd-admin2/bin/perl: 2: /usr/local/pd-admin2/bin/perl: Syntax error: "(" unexpected


    *** Import der neuen/ge▒nderten Dateien/Verzeichnisse ***
    *** kann wegen eines Dateitypkonflikts nicht vorge- ***
    *** men werden. ***


    Hat das schon jemand gehabt?