Beiträge von Chiifii

    So wie ich das sehe sind hier einige libs nichtmehr vorhanden, ich gehe der Sache mal nach


    http://paste.bradleygill.com/index.php?paste_id=322387


    Code
    22977 open("/usr/local/pd-admin2/lib/mysql/tls/i686/sse2/cmov/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory) 2
    2977 stat64("/usr/local/pd-admin2/lib/mysql/tls/i686/sse2/cmov", 0xfff35cb8) = -1 ENOENT (No such file or directory)
    22977 open("/usr/local/pd-admin2/lib/mysql/tls/i686/sse2/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
    22977 stat64("/usr/local/pd-admin2/lib/mysql/tls/i686/sse2", 0xfff35cb8) = -1 ENOENT (No such file or directory)
    22977 open("/usr/local/pd-admin2/lib/mysql/tls/i686/cmov/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
    22977 stat64("/usr/local/pd-admin2/lib/mysql/tls/i686/cmov", 0xfff35cb8) = -1 ENOENT (No such file or directory)
    22977 open("/usr/local/pd-admin2/lib/mysql/tls/i686/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
    22977 stat64("/usr/local/pd-admin2/lib/mysql/tls/i686", 0xfff35cb8) = -1 ENOENT (No such file or directory)


    ... Könnte evtl. etwas damit zu tun haben ;)



    Kann mir jemand, bei dem alles Funktioniert den strace.log von "strace -fF /service/qmail-smtpd/run" schicken / hier posten, damit ich die 2 logs vergleichen kann?


    MfG

    /service/qmail-smtpd/run meldet gar keine Ausgabe.


    Bei einer telnet Anfrage erhalte ich:


    telnet localhost 25
    Trying 127.0.0.1...
    telnet: Unable to connect to remote host: Connection refused



    interessant ist auch noch netstat -lpn


    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 24022/sshd
    tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 24924/mysqld
    tcp 0 0 127.0.0.1:783 0.0.0.0:* LISTEN 24740/perl
    tcp6 0 0 :::21 :::* LISTEN 24715/proftpd: (acc
    tcp6 0 0 :::22 :::* LISTEN 24022/sshd
    tcp6 0 0 :::443 :::* LISTEN 24736/httpd
    tcp6 0 0 :::587 :::* LISTEN 24707/tcpserver
    tcp6 0 0 :::110 :::* LISTEN 24699/tcpserver
    tcp6 0 0 :::143 :::* LISTEN 24711/tcpserver
    tcp6 0 0 :::80 :::* LISTEN 24736/httpd



    Daher würde ich behaupten, funktioniert ein Programm seit dem Upgrade nichtmehr - denn gestartet (und überprüft!) habe ich alle Dienste.


    wäre ein Downgrade eigentlich möglich?

    Nach dem Update auf der Serverumgebung 0.177 lässt SMTP auf dem Server keine Verbindungen mehr zu.


    Bei einer telnet Anfrage erhalte ich:


    telnet localhost 25
    Trying 127.0.0.1...
    telnet: Unable to connect to remote host: Connection refused


    Die Email Logfiles geben keinen Aufschluss.
    Hatte jemand bereits ein solches Problem mit dem Port 25? Falls ja, könnte er mir bitte einen Lösungsansatz verraten?


    MfG

    Ich habe das Update auf SE 177 durchgeführt, jedoch geht nun der Mailserver hinten und vorne nichtmehr.


    Könnt Ihr mir sagen wo ich eine SMTP Logfile finden kann?



    Squirrelmail zeigt mir folgenden Fehler an:


    ERROR:
    Message not sent. Server replied:
    Connection refused
    111 Can't open SMTP stream.




    P.S.: Die Anleitung über telnet funktioniert gleich am Anfang schon nichtmehr, liegt vielleicht daran, dass der Server verbindungen über Port 25 zurückweist, allerdings erst nach dem update

    Hallo,


    Ich suche nach einer Möglichkeit meinen Kunden übers Interface das Extrahieren von Archiven anbieten zu können. Dies würde vor allem Kunden mit einer langsamen Internetverbindung freuen, aber auch meinen Trafficverbrauch.


    Besonders wichtig wären mir die Linux Archivformate, sowie Zip, Rar und 7zip.


    Kennt da jemand eine Lösung die ich einbauen könnte?

    Super, das mit dem Patch ist die beste Lösung ;)


    Und bei dem "Ohne weiteres" hab ich ja oben hingeschrieben: "Crypt: keine Ahnung & keine Möglichkeit zum testen, aber bei md5 durchgeführt und getestet"


    Genau aus dem Grund denke ich, dass die Passwortlänge noch nicht erhöht wurde, da es im Crypt System vielleicht nicht ohne weiteres möglich ist, aber dies ist nur eine Mutmaßung.
    Wobei ich mich frage, weshalb das Cryptsystem überhaupt noch angeboten wird und dann noch an erster Stelle.

    Da ich wie viele Kollegen hier das Problem mit der Passwortlänge hatte, habe ich getestet ob man eventuell selbst gegen dieses Problem vorgehen kann.


    Dies ist sogar relativ leicht, weswegen ich euch nicht alles im Detail erklären werde, da es Idiotensicher ist die Passwortlänge zu erhöhen.


    1. Vergewissert euch, dass ihr das md5 System installiert habt, ich habe es fürs crypt System nicht getestet und weiß auch nicht ob es funktioniert!


    2. Ihr geht auf eurem Server in das Verzeichnis /opt/pdadmin/www/html/. Dort findet ihr die HTMLs für Admins und Customers. Zunächst wollen wir für unsere Kunden die Passwort länge erhöhen:


    3. Ihr öffnet im Unterordner Customers


    db.create.html
    db.passwd.html
    ftp.create.html
    ftp.passwd.html
    login.failed.html
    login.html
    logout.html
    passwd.html
    pop3.changepasswd.html
    pop3.create.html
    pop3.passwd.html
    user.main.passwd.html


    und sucht in diesen Dateien einen Abschnitt, der sich i.d.R. im letzten drittel befindet und i.d.R. folgenden Code beinhaltet:


    Code
    <td><input type="password" name="passwd" maxlength="8" class= "formulartext c2"></td>


    Hier ändert ihr

    Code
    maxlength="8"


    zu eurer Wunschgröße, ich habe z.B. 64 genommen.

    Code
    maxlength="64"


    Bitte erstellt zur Sicherheit ein Backup von jeder Datei!


    Danach macht ihr das gleiche im Ordner administrator mit folgenden Dateien:
    customers.passwd.html
    login.failed.html
    login.html
    logout.html
    subresellers.create.html
    subresellers.passwd.html


    Viel Spaß mit eurer neuen Passwortlänge ;)


    MFG ChiiFii