Beiträge von Twilo

    bisher hat sich noch kein Kunde beschwert :/


    jetzt meldet sich der Mail-Server mit mail.example.org, der Exchange macht trotzdem zicken …


    weiß jemand, was folgende Logzeile bedeutet?

    Code
    1. 2019-09-06T07:01:05.112Z,XXX Smarthost,AAAAAAAAAAAAAAA,8,192.168.XXX.XXX:10959,178.63.XXX.XXX:25,*, CN=EX1 CN=EX1 DDDDDDDDD EEEEEE 2019-08-22T13:33:35.000Z 2024-08-22T13:33:35.000Z EX1;EX1.example.local,Sending certificate Subject Issuer name Serial number Thumbprint Not before Not after Subject alternate names

    versucht der Client ein Zertifikat zu senden?

    Könnte es sein, dass das Problem folgendes ist?

    Das Zertifikat ist auf mail.example.org ausgestellt, der Hostname jedoch s3.example.org, das steht auch in der /var/qmail/control/me Datei.


    Andere Clients haben damit kein Problem :/

    Hallo,


    was bedeutet folgende Zeile?

    Code
    1. TLS negotiation failed with error IllegalMessage

    Hallo,


    vielen Dank.


    Gibt es noch eine weitere Log, außer /var/log/mail.log?

    Wenn die TLS Option im Exchange aktiviert wurde, sehe ich in der mail.log keinen Eintrag. Wo werden die TLS Einträge geloggt?


    Im qmail-smtpd run-File habe ich folgendes hinzugefügt:

    Code
    1. export FORCETLS=1

    Hallo,


    hat hier schon jemand Exchange 2019 unter Windows Server 2019 so zum Laufen bekommen, dass Exchange über pdadmin (qmail mit TLS required) Mails versenden kann.


    Vorher lief ein Exchange 2010 (auf 2018R2) und da funktionierte es.


    Nach dem Versuch eine Mail zu versenden, erscheint dort

    Code
    1. [{LED=451 4.4.395 Target host responded with error. -> 421 4.4.1 Connection timed out};{MSG=};{FQDN=x.example.com};{IP=123.0.0.123};{LRT=26.08.2019 09:10:49}]

    Wenn das TLS Häkchen in Exchange entfernt wird, erscheint die Meldung, das TLS benötigt wird.


    Woran kann das liegen?

    ich würde erstmal schauen, ob bei den Verzeichnissen etwas auffällt

    Code
    1. du -hcs /* 2>/dev/null |sort -h
    Code
    1. du -hcs /tmp /var/log /var/tmp/ /usr/local/pd-admin2/tmp /usr/local/pd-admin2/logs/ /usr/local/pd-admin2/var/log/ /usr/local/pd-admin2.* $(grep '^$backup_dir' /opt/pdadmin/etc/pdadmin.conf |cut -d"'" -f2)

    Wenn man nur $HOME/logs angibt, kommt /root/logs raus, da die Variable schon in der backup.pl ausgewertet wird, durch \ kann man es eigentlich an einen Skript durchreichen, warum es dann in der backup_user.sh nicht ausgewertet wird … hm …


    der Aufruf sieht dann wie folgt aus

    Code
    1. USER 22357 14.5 0.0 26140 2576 pts/0 SN+ 09:19 0:00 tar --preserve-permissions --exclude=$HOME/logs -czf /backup/user/USER/0/backup.tar.gz /home/USER

    erwartet hätte ich

    Code
    1. USER 22357 14.5 0.0 26140 2576 pts/0 SN+ 09:19 0:00 tar --preserve-permissions --exclude=/home/USER/logs -czf /backup/user/USER/0/backup.tar.gz /home/USER

    :/