Letzte Aktivitäten

  • Sumeragi

    Hat eine Antwort im Thema
    • [erledigt]
    kein administrator - Zugang mehr verfasst.
    Beitrag
    Die Zertifikate wurden offenbar nur aus /etc/letsencrypt/live gelöscht, jedoch nicht aus /etc/letsencrypt/renewal/. Im Log sieht man ja, dass er die Konfig daraus verarbeitet.

    Bei vpscobra.service4it.com kommt es erneut zu einem 404 Fehler. Also immer…
  • RudiX

    Hat eine Antwort im Thema
    • [erledigt]
    kein administrator - Zugang mehr verfasst.
    Beitrag
    Hi,
    habe /opt/pdadmin/bin/certbot-auto renew --dry-run gestartet, (siehe txt-file im Anhang) es werden einige Fehler ausgegeben.
    Er sucht nach den vpscobra.service4it.com-001 und ...-002 files, die ich gestern gelöscht habe. Aber das Zertifikat für…
  • Sumeragi

    Hat eine Antwort im Thema
    • [erledigt]
    kein administrator - Zugang mehr verfasst.
    Beitrag
    Dies kann zumindest getestet werden mit
    (Quelltext, 1 Zeile)

  • Eisenherz

    Hat eine Antwort im Thema
    • [erledigt]
    kein administrator - Zugang mehr verfasst.
    Beitrag
    Normalerweise sollten sich die Zertifikate jetzt automatisch verlängern, wenn der Cron-Job richtig läuft.
  • RudiX

    Like (Beitrag)
    (Zitat von Eisenherz)


    Nicht nur irgendwie, sondern das Problem wird auch konkret benannt im Log:

    (Quelltext, 10 Zeilen)


    Die Dateien unter /etc/letsencrypt/live/vpscobra.service4it.com/ sind keine Symlinks. Eigentlich sollten die Dateien dort auf…
  • RudiX

    Like (Beitrag)
    Es scheint ja, dass der Config File unter /etc/letsencrypt/renewal/vpscobra.service4it.com.conf


    2018-09-20 21:10:20,003:DEBUG:certbot.cert_manager:Renewal conf file /etc/letsencrypt/renewal/vpscobra.service4it.com.conf is broken. Skipping.
    2018-09-20…
  • RudiX

    Hat eine Antwort im Thema
    • [erledigt]
    kein administrator - Zugang mehr verfasst.
    Beitrag
    ... so Männers, nachdem ich mir inzwischen Twilo's Thread "Let's Encrypt für den Servername verwenden" angeschaut habe, bin ich endlich ans Ziel gekommen.


    Habe nun folgenden Aufruf manuell gestartet:
    /opt/pdadmin/bin/certbot-auto certonly --agree-tos…
  • RudiX

    Hat eine Antwort im Thema
    • [erledigt]
    kein administrator - Zugang mehr verfasst.
    Beitrag
    Hallo,
    also der curl -L ... Aufruf bringt folgende Ausgabe:
    curl: (60) SSL certificate problem: self signed certificate
    More details here: http://curl.haxx.se/docs/sslcerts.html

    curl performs SSL certificate verification by default, using a "bundle"
    of…
  • Sumeragi

    Hat eine Antwort im Thema
    • [erledigt]
    kein administrator - Zugang mehr verfasst.
    Beitrag
    (Zitat von RudiX)


    Hierbei nicht bitte irritieren lassen. Es fehlt lediglich das Newline hinter certbot-auto failed. Richtig sähe es so aus:

    (Quelltext, 4 Zeilen)


    Es hat nichts mit dem Schreiben der httpd.conf zu tun ;)
  • Sumeragi

    Hat eine Antwort im Thema
    • [erledigt]
    kein administrator - Zugang mehr verfasst.
    Beitrag
    (Zitat von Eisenherz)


    Nicht nur irgendwie, sondern das Problem wird auch konkret benannt im Log:

    (Quelltext, 10 Zeilen)


    Die Dateien unter /etc/letsencrypt/live/vpscobra.service4it.com/ sind keine Symlinks. Eigentlich sollten die Dateien dort auf…
  • Eisenherz

    Hat eine Antwort im Thema
    • [erledigt]
    kein administrator - Zugang mehr verfasst.
    Beitrag
    Es scheint ja, dass der Config File unter /etc/letsencrypt/renewal/vpscobra.service4it.com.conf


    2018-09-20 21:10:20,003:DEBUG:certbot.cert_manager:Renewal conf file /etc/letsencrypt/renewal/vpscobra.service4it.com.conf is broken. Skipping.
    2018-09-20…
  • RudiX

    Hat eine Antwort im Thema
    • [erledigt]
    kein administrator - Zugang mehr verfasst.
    Beitrag
    Hallo Eisenherz,
    also beim Aufruf von /opt/pdadmin/bin/letsencrypt vpscobra.service4it.com wird dieser Log-file geschrieben.

    Nochmal zum Verständnis:
    der hostname -f ist: vpscobra.vpscontrol.net
    der ServerName in der /usr/local/pd-admin2/httpd-2.4/conf…
  • Eisenherz

    Hat eine Antwort im Thema
    • [erledigt]
    kein administrator - Zugang mehr verfasst.
    Beitrag
    Hänge wirklich am besten mal das Log an, dann können wir vielleicht mehr daraus erkennen.
  • RudiX

    Hat eine Antwort im Thema
    • [erledigt]
    kein administrator - Zugang mehr verfasst.
    Beitrag
    Hallo Sumeragi, Hallo Eisenherz,


    der RedirectMatch hat leider auch zu keinem Erfolg geführt ;-((
    Da ich inzwischen zu oft den letsencrypt-Aufruf gestartet habe erscheint erstmal eine Sperre.
    There were too many requests of a given type :: Error creating…
  • Sumeragi

    Beitrag
    (Quelltext, 2 Zeilen)

    Die Fehlermeldung ist ja eigentlich eindeutig. qmail-remote konnte kein IPv6 Socket erstellen. Es gilt also heraus zu finden, wann und weshalb es auftritt. Hat der Empfänger vielleicht nur eine IPv6 Adresse? Wie sieht die…
  • Sumeragi

    Hat eine Antwort im Thema
    • [erledigt]
    kein administrator - Zugang mehr verfasst.
    Beitrag
    Ich sehe gerade, der Pfad ist
    (Quelltext, 1 Zeile)

    es kann sein, dass durch die Weiterleitung auf HTTPS beim Hostnamen der Aufruf der Validierungsdatei fehlschlägt. In dem Fall muss der vhost für den Hostnamen in der Apache angepasst werden.
    Einfach die…
  • Sumeragi

    Hat eine Antwort im Thema
    • [erledigt]
    kein administrator - Zugang mehr verfasst.
    Beitrag
    Es kommt zu einem 404 Fehler. Sprich die hinterlegte Validierungsdatei wird nicht gefunden.
    Sofern die IP im DNS mit der in pd-admin übereinstimmt, muss man prüfen wo let's encrypt die Datei anlegt. Wahrscheinlich…
  • Eisenherz

    Hat eine Antwort im Thema
    • [erledigt]
    kein administrator - Zugang mehr verfasst.
    Beitrag
    Also, wenn ich das Zertifikat hier

    https://sslanalyzer.comodoca.c…l=vpscobra.service4it.com

    prüfen dann zeigt er an, dass das Zertifikat selbst signiert wurde.

    Also scheint er kein Let’s Encrypt Zertifikat erstellt zu haben, was die Fehlermeldung…
  • RudiX

    Hat das Thema
    • [erledigt]
    kein administrator - Zugang mehr gestartet.
    Thema
    Hi @ all,

    bin mittlerweile auf pdadmin ver 4.58 und se 0.317.
    Der Server läuft unter Debian 8.11 auf Cloudserver-50


    Problem: kann meine administrator - Oberfläche mit Mozilla Firefox nicht mehr aufrufen.
    Meldung von Mozilla:
    Der Inhaber von…
  • tbc233

    Beitrag
    Dürfte trotzdem nicht zu so einer Fehlermeldung führen. Ich hatte schon 100.000 und mehr Mails in der Queue, das bringt qmail (verzögerte Zustellungen natürlich jetzt mal abgesehen) eigentlich nicht aus der Ruhe.